Shield TV and Fire Stick 4K scrubing lock up

So I have just started using Channels DVR and its great compared to others I've tried. So when I'm using either 4k Fire Stick or Nvidia Shield and remote to the DVR with settings at 4Mb 720p I can start watching a recording and scrub forward and back to wherever I want and everything works fine. After watching for around 5 minutes if I scrub backward past the buffer, like 20 minutes or so the unit will never recover playing. Backing out to the menu and hitting watch again fixes the issue easily and quickly. Backing out and starting it again remembers the position that I was trying to scrub back to, and that effectively allows me to continue to scrub to wherever I want until I've been watching for 5 minutes or more again. The playback freeze only happens when going backwards, forwards always works including skipping commercials. It happens on a 2015 shield TV and a 2018 (brand new) 4k Fire Stick, but not on my ipad IOS. As I said it only happens after watching for 5 minutes or so then going backwards past the buffer, and I'm remote to the DVR with a 10 Mb speed, 40 ms ping, 6 ms jitter. I tried hardware and software decoders on the shield, and hardware and software encoders on the server. Sometimes I get an audio squeal after playback locks up but I think if the playback would start again it would fix that too.

G5500 8th gen Intel CPU with iGPU
8 GB Ram
3.5" 7200 RPM 2 TB Internal Harddrive

2015 Nvidia Shield
2018 4K Fire Stick
Iphone and Ipad

Edit: Just wanted to clarify that this issue happens every time on the two android TV clients and is easily reproducible.

Is the app frozen when this happens? Can you back out of the player and submit diagnostics from the app's settings tab?

No the app is fine, I just back out, one click, then click watch again. It only takes 1-3 seconds to get it to play again. I can submit diagnostics.

Just submitted diagnostics

Hi @tmm1
Were you able to reproduce?



Just a friendly bump. Just wondering if anyone else can reproduce the issue. Its easy, just watch a program on the Shield or Fire-tv 4k for longer then 5 minutes, then try to go back 20 minutes without backing out to the watch screen and see if it picks up playing again or cursor just circles indicating its working to pick up the stream again. Because the issue is going back you have to be at least 20 minutes into the program. It does it every time no matter the content.

Have you tried turning off transcoding and set your clients to original quality while using your internal Network?

It works fine on direct play original quality, so the problem seems to be related to transcoding. It seeks just fine when you first start playing the file but something happens after 5 minutes that you can't go back 20 minutes without backing out and selecting watch again. I am remote to the my server a lot which is why transcoding is a must.

This occurs on both my 2015 shield and 2018 4K Fire stick (latest, purchased in 2020). My iOS clients work fine and the Apple TV works fine. This makes sense because the Apple TV app is probably very similar to the iOS app and the shield app is close to the fire TV app. When the scrubbing lock up happens the server just stays in the (transcoder ready), and the server has is at idle cpu load if that helps. Either the cache is not being sent or the server is not transcoding the new file position. Maybe the server is assuming the client already has the content.

I’m don’t expect a fix, I would just like confirmation that it is a bug and that it could possibly be fixed in the coming months. I just subscribed for a year as this is the best dvr I’ve tried after Plex and Emby so I’m not trying to be overly critical of the software.

We need diagnostics from the app after this happens. No one else has reported a similar issue so we don't know yet where the problem exists.

EDIT: the diagnostics from before show part of the problem but not enough to make sense of entire issue. We would like you to enable http logging on the dvr and then email the dvr logs as well along with submitting diagnostics so we can see what's happening on both the transcoder and the client watching.

Ok maybe I understand.... then is when you are away from home. You may start a program 1/2 way in then 5 minutes later decide to go back to the beginning lets say to start over and it hangs?

If so... you need to perform the action, when it happen go into the DVR section and send a diagnostic log and inform channels support via email and here that you have sent this info so they can look into it.

Did you not get the diagnostics I sent 22 days ago? Any how I just submitted diagnostics again.

After reproducing it again, I think you only have to wait until the server finishes transcoding and displays "Transcoder Ready" on the web interface, then you can't rewind past 10 minutes, without having to restart the play by hitting back button then selecting "watch" again.

@jpblanch75 That is exactly what is happening.

@tmm1 I submitted diagnostics again, after http enabled logging, and emailed the server logs to [email protected]

1 Like

I’ve been able to reproduce this issue. I’ll let you know when we have a fix.


I'm glad to here it and thank you for confirming my sanity. I look forward to the fix.