Shield TV - Live channel view goes back to guide after a few minutes

I’ve been using the betas of Channels on my Shield TV for quite some time now, and this new issues cropped up a few days ago. I’m currently running version 1.0.21 of the app. If I tune to a live channel, I’m kicked back to the guide (or on now, depending what I was last in). I can then tune right back into live TV, but this problem continues. The amount of time between instances seems random. Sometimes just a few minutes, sometimes over ten minutes.

To see if it was my HDHR Prime causing the issue, I’ve tried continuous playback on my iPhone and I have no such problem on there. The live video just continues to play for as long as I let it.

1 Like

Hm, strange. When this happens again can you go to Player Settings and click Submit Diagnostics?

Sure. I actually did submit diagnostics right after the most recent one a couple hours ago. Not sure if you can dig through and find it though.

The only log I see is empty, which might mean the app crashed. When it leaves the player, does it briefly flash “no favorite channels” or something similar before the channels load in?

Can you find the IP of your shield, and open http://x.x.x.x:57000/log?show=all and then file>save to send to [email protected] after it does it next time.

I think I found the issue. Just uploaded a beta build (66) to Play Store.

(Not sure though, so logs would still be helpful).

I updated and been going for quite a while now without the player crashing, so I think you fixed it. Since it’s not crashing anymore, I won’t be able to get you a useful log.

1 Like

Great, thanks for confirming. I’ve released v1.0.22 with the fix.

Note: I tried playing a recording (Tonight Show) on 1.0.22 on my Sony TV and it consistently crashed Channels. (Diagnostics submitted.). I then tried on Apple TV and FireTV 1.0,21—both played same show fine. I went back to 1.0.22 on the Sony and it wouldn’t play, but just returned to Channels home screen. Two more tries started the show fine. Then, another try crashed the app.

Note: I don’t actually use the apps on the Sony and FireTV other than checking progress on the app. Other shows seem to play fine, but two of the five Tonight Shows have this problem. I do not know if they would have played fine on 1.0.21 on the Sony.

Not seeing any crash reports. Can you trigger again, then use http://x.x.x.x:57000/log?show=all to grab the logs and email to [email protected]

It looks like the log is showing the previous crashes. Will this suffice?

--------- beginning of crash
05-05 17:07:46.956 8063 8192 F libc : Fatal signal 6 (SIGABRT), code -6 in tid 8192 (CodecLooper)
05-05 17:08:36.598 8415 8524 F libc : Fatal signal 6 (SIGABRT), code -6 in tid 8524 (CodecLooper)
05-05 17:09:12.095 8541 8670 F libc : Fatal signal 6 (SIGABRT), code -6 in tid 8670 (CodecLooper)
05-05 17:09:49.289 8698 8812 F libc : Fatal signal 6 (SIGABRT), code -6 in tid 8812 (CodecLooper)
05-05 17:12:59.028 8830 9693 F libc : Fatal signal 6 (SIGABRT), code -6 in tid 9693 (CodecLooper)
05-05 17:16:58.506 9916 10042 F libc : Fatal signal 6 (SIGABRT), code -6 in tid 10042 (CodecLooper)
05-05 17:20:24.935 10323 10508 F libc : Fatal signal 6 (SIGABRT), code -6 in tid 10508 (CodecLooper)
05-05 17:21:06.123 10687 10856 F libc : Fatal signal 6 (SIGABRT), code -6 in tid 10856 (CodecLooper)

I cannot get any more logs with

The browser hangs and eventually the app crashes. does work, but it’s not so useful. After I restart the app, I get the following:

1.0.22 (67 store)
SDK 7.0 (24) armeabi-v7a, armeabi
en_US America/Los_Angeles

--------- beginning of main
05-05 19:02:19.106 16200 16200 I chatty : uid=10117( expire 17 lines
05-05 19:02:19.654 16200 16210 I chatty : uid=10117( HeapTaskDaemon expire 1 line
05-05 19:02:19.808 16200 16274 I chatty : uid=10117( mpv-events expire 3 lines
05-05 19:02:20.047 16200 16279 I chatty : uid=10117( NsdManager expire 5 lines
05-05 19:02:20.169 16200 16282 I chatty : uid=10117( RenderThread expire 3 lines
05-05 19:02:20.181 16200 16205 I chatty : uid=10117( Jit thread pool expire 8 lines
05-05 19:02:20.550 16200 16281 I chatty : uid=10117( expire 3 lines
05-05 19:02:21.558 16200 16280 I chatty : uid=10117( expire 1 line
05-05 19:02:23.617 16200 16304 I chatty : uid=10117( glide-disk-cach expire 72 lines
05-05 19:02:24.040 16200 16305 I chatty : uid=10117( NanoHttpd Reque expire 1 line
05-05 19:02:24.114 16200 16304 I chatty : uid=10117( glide-disk-cach expire 5 lines
05-05 19:02:24.182 16200 16304 I chatty : uid=10117( glide-disk-cach expire 11 lines
05-05 19:02:24.299 16200 16304 I chatty : uid=10117( glide-disk-cach expire 16 lines
05-05 19:02:24.398 16200 16304 I chatty : uid=10117( glide-disk-cach expire 12 lines
05-05 19:02:34.394 16200 16314 V ApiServer: REQUEST: GET /log

Presumably, the show=all would reveal the previous crashes.

In any event, I’m just passing on them info. I use the AppleTV for viewing.

I did manage to get the log and sent relevant portions. There is an OOM, but that may have been caused by trying to get the log. Just not sure.

Ugh yea looks like it’s crashing when trying to fetch the log.

Can you see if the recording plays when you turn off the Surround Sound option.

Still crashes with surround sound off. I was able to get the log. I’ve sent it.

It would be easier to fetch the logs if this wasn’t repeated a bazillion times:
05-06 10:44:59.171 11472 11472 E libc : Access denied finding property “persist.mtk.mlog2logcat”


Uploaded beta build 68 to play store

Beta 68 works like a charm. I can play all of the episodes. Thanks!

(1) Surround sound turned back on for test.
(2) OOM problem still exists when fetching log.

1 Like

Also note: I now see 1.0.22 on FireTV and there is no issue playing the aforementioned episodes.

Sorry to reopen but I’m having this issue as well. I’ve just uploaded logs.

Could you select Crash when uploading? Is the app restarting and showing a spinner and loading data when it leaves the player?

It looks like you're running quite an old beta build from May 1st. Please update the app from the Play Store.