Shield v8.2.3 playback failed

I thought I somehow skipped the whole version 9 mess on my Shield due to declining to upgrade the software because of the warnings from the community. It's been working great every day until about an hour ago. I'm currently on v8.2.3 and my Shield doesn't seem to be reading my external drive anymore.
Anyone have any ideas? Anyone else experiencing this?

When I try connecting my hard drive to my windows laptop, it's asking me to format it. I would like to attempt to recover my settings and set up my DVR on my Windows machine while this gets sorted out, but does anyone know how to recover files that seem to be lost on the hard drive? Or are my DVR settings stored on the cloud anywhere possibly?

Was it internal or removable storage on the shield?

There should be a copy of the settings.db in the app installation, but I'm not sure how best to access it on your shield.

I think it was removable storage, but do you think if it was internal, that they could be why windows isn't reading it?

I think I am able to access the internal drive from windows by using Network share. I see a folder called Internal with subfolders: Android, DCIM, etc. Nothing with Channels or DVR. I searched for *.db and only found Plex related search results

It's in this directory:


But you may not have permissions to read it.

It seems your drive was removable so if it's not being recognized I guess it got corrupted?

Maybe you can find some recovery program for your PC that can fix it

Thanks, I don't think I know how to access that directory.
Anyone have any recommendations as to which recovery software I can try using Windows? Google has too many paid ads or spam advertising as free. It's tricky to find.

Looks like you can do it via adb.

adb connect x.x.x.x
adb backup -noapk

I think I need a few more instructions. I was able to connect to my Shield using an app on my Android phone called "Remote ADB Shell". When I connect to my {Shield IP}:5555 I get a text screen that starts with mdarcy:/ $
I tried entering adb backup -noapk but I get:
/system/bin/sh: adb: not found

I don't think that remote shell thing will work. It only runs adb shell and adb backup is a different command.

Best bet would be to install adb or android studio on a PC and run things from there.

Thanks, almost there... I cleared the error I was getting using adb backup as I had to look at my Shield and allow the connection. Anyway, what exactly happens now? I think I have a file called backup.ab on my PC that's 27MB, I dont think that was there before. How do I use this to restore my database on my PC?

Search for "android backup file extractor"

You need to unzip the .ab basically and then inside you'll find the settings.db and recorder.db

This may be a bit too technical for me. I'm really kind of lost trying to mess with java and powerscript

Maybe try droid explorer?

I'm sorry for being so lost here but this is what I'm getting:

I have no password on the backup.ab file

No worries, you're very close.

  1. make sure the backup.ab has been copied to that same directory

  2. run it again, but remove the < and >

java -jar abe.jar unpack backup.ab backup.tar

Then you can open backup.tar and get the files inside

Thanks, I thought I tried that, but still getting error:

Does abe.jar exist in that directory?


I can't tell if that's a jar file

But it looks like there's a backup.tar in that directory now, so maybe you can open that