Slow DVR Performance on 4th Gen Apple TV (Windows)


I have been using Channels DVR for almost two years now and it has worked incredibly well during that time. But in the last couple of weeks, I have noticed a significant drop off in performance when I am accessing DVR programming from my two 4th Gen Apple TV units. When I press the skip button while watching DVR programming, there is a lag of approximately 2-3 seconds before it skips forward. When I double-click for commercial skip, it takes about 4-5 seconds to perform the action. I also own a 4K Apple TV that is not experiencing these Channels issues. On the 4K unit, when I hit the skip button, it performs the function instantly.

Some information on my setup:
-DVR on Windows PC running Windows 10. i7 processor, 8GB RAM, 4TB HDD
-Running version 2018.10.30.0010 of DVR. I was using the up-to-date public release, but upgraded to beta to see if that would fix the issue.
-Running version 3.2.10 of the app on my Apple TV.
-All three of my Apple TV units are hard-wired
-All other programming on my Apple TVs still functions perfectly.


Sounds like a network perf issue.

Can you run a speedtest between the PC and the Apple TV. While the Channels app is running, open http://x.x.x.x:57000/speedtest on the PC using the IP of the ATV4K.


The IP address of my Apple TV 4K is I tried to access:

I tried several times and it kept saying, 'This site can't be reached'

I can ping it and get 32 bytes in <1ms. That probably doesn't help you much.


The channels app must be running and visible on screen for the speedtest to work.


Apple TV 4K:
Download 945 Mbit/s
Latency 3.38 ms
Jitter 0.59 ms

Apple TV 4th Gen (1):
Download 100.76 Mbit/s
Latency 5.10 ms
Jitter 0.57 ms

Apple TV 4th Gen (2):
Download 100.84 Mbit/s
Latency 4.84 ms
Jitter 0.44 ms


Everything looks normal. The reason the 4K is so much more responsive is because it has a gigabit ethernet port. The ATV4 only have 100mbps port, so it takes 10x longer to download the new part of the video file whenever you try to jump around.

If you have good wifi, you could switch those devices to wifi and get 5x speed improvement.


I have great wifi (Orbi AC3000 mesh system with 2 satellite nodes). However, I have always appreciated the stability and consistency of wired ethernet. And like I said, my setup has worked flawlessly for quite some time. I wasn't sure if there was a recent update to the DVR or App that would have caused my setup to suddenly change in performance.


If the same version of Channels is working fine with the same instance of the DVR on the 4K TV but not the others, then it doesn't seem like it's a software issue.

The app hasn't changed much recently. When did you first start noticing problems? I can check the DVR changes to see if there might be anything related, but I'm puzzled how any software change could affect only 100mbps connections.


It is definitely odd. But I would think that for this application, there wouldn't be a noticeable difference between a 1000 and 100 mbit/sec connection.

I switched to wireless on both units and the performance is significantly better. I am still puzzled as to the sudden change in performance within a matter of weeks over my wired connection.


Most internet streams are heavily compressed H264, but the video from the HDHR is raw mpeg2. mpeg2 uses a ton more bandwidth (2MB per second of video), and also is just a raw stream with no indexes. So to seek, the player has to basically guess where 30s ahead might be, download some video from that location in the file, check to see if it actually is 30s ahead and adjust slightly forward or backwards if needed. It's very bandwidth intensive, especially for high bitrate recordings from HD OTA channels.

I can't explain why the behavior changed for you though. I can tell you that this has been a known issue on our end for years with the ATV4.


I sorta had this happen when i changed from the home streaming quality from original to something else and the performance just sucked for the skipping. so I put it back to original and back to normal


I noticed the same exact lag as OP, I noticed after Apple TV update. I have 3 Apple TV 4k for about a year. Both my wireless and wired apple tvs have the same problem. My speed test numbers are:





This happened to me also. For a long time I ran the DVR on my Windows Home Server and there were no problems. I can't pinpoint when it happened but when it did I thought it was because I use a stablebit drive pool on my server and it was having problems with that. I switched to an ubuntu server DVR install and the problem went away. Now I'm trying to go back to the Windows Server install on a dedicated Seagate Constellation ES3 hard drive (actually tried several) and it is doing the same thing. Funny thing is, when I use the Ubuntu server DVR (which is on much older hardware) it works fine and skips instantly. I can turn that DVR off, turn on the Windows one and the problem returns. All 7 of my ATV4's are hardwired gigabit with cat6e and have no issues with anything except for the Windows Channels DVR slow skipping. The fact that skipping performs flawlessly on older hardware running Ubuntu tells me that something changed in the Windows software.


@Marino13 Can you run a speedtest as outlined above and post the results?

It's possible that a DVR server update is affecting disk read performance on Windows. What version of windows are you running?



WHS 2011


I have also verified that other media player apps play the files fine and skip instantly on the same exact files. All of the recordings in the DVR folder skip fine with MrMc, Emby and Plex with no transcoding.


Can you try measuring speed test downloading a recording. You will need a file ID from the Log, then download http://x:8089/dvr/files/ID/stream.mpg on the same computer and from another device and measure the download speed. If you download curl.exe you could run a command like this which would show speeds as it downloads:

curl.exe -o nul


Alternatively you can feed that same url into MrMC and see if seeks also get slow there when reading the media from Channels DVR.


13 37

These are from two LAN connected PC's running Windows 10. 42 is the Ubuntu DVR and 77 is the Windows DVR. As you can see the Windows DVR is half the speed as the Ubuntu. For some reason when I run it locally on the server I get a curl: (23) Failed writing body (0=!27) error. My server doesn't have curl installed so I just downloaded the Windows version and threw it in a folder on the C drive. It may not actually be installed correctly. I can't seem to figure out how to input the url into MrMC. If you can guide me on where to go with that it would be appreciated.

Channels DVR Windows recordings lags when skipping

Same issue over here, I was running Channels DVR on a old MacBook (connected with Ethernet) and it worked flawlessly with ATV 4th Gen with Ethernet. I have since switched over to a windows server and it takes it a few seconds to seek on Ethernet while on WiFi it seeks quickly. How would the data rate change from Mac to Windows?