Sound Issues with Onn Android TV Streamer

I have been trying out the Onn Android TV Streamer off and on for a while to see if it would be a better device than my TS4K. However, I have an issue that makes it pretty much unusable.

Channels DVR (and Hulu and Amazon Prime) all have incredibly low volume levels. So low that if I turn it up to a reasonable volume, switching to any other app, the home screen, or another input results in way way too loud volume.

Just for reference, this happens on my Samsung QN65Q7DRAFXZA TV with or without my Sonos Beam plugged into the ARC port. As I am typing this, I realized that I haven't tested the device on my other TV (I might try that tomorrow if I remember).

This seems to be an issue with the Onn device, as nothing else has this type of problem.

  • I was hoping someone maybe had an idea how I might get it fixed (or contact Onn).
  • If you have any ideas of settings that I might be able to try, that would be good as well. I did try the settings under Sounds, but no luck so far.
  • Also, if anyone knows what those particular apps have in common, that could help too. The following apps have no problems: Netflix, Disney+, HBO Max, and Vudu.

Thanks,
Josh

I just picked a one of these devices (not the dongle) a month ago, and I don't have a volume level issue. Initially there was an issue with not getting any sound, but that was resolved by changing the Sound options under Device Preferences. In my case I had to turn off Dolby Digital.

After trying the device on my other TV and it still having the problem, I factory reset it. Now the volume is all reasonable now. I guess it was just some strange state the device got into (strange that it never worked for me though).
Thanks,
Josh

1 Like

I have the non-dongle version as well. I’ve had issues with the sound. Go into the settings and turn CEC on. Then turn it off. It fixes the sound. Strange issue. I’ve never seen that before. Luckily I tried that before I did a factory reset. I have to do this periodically.

1 Like

I will try this if it comes back. I had CEC turned off at the time. Right now I think I left it on, but hopefully this works.