Ssh no longer works on my Channels DVR RPi 4 instance


I am using the RPi 4 Channels DVR image and need to ssh into it to remove a file /mnt/data/channels-dvr/data/chromedata/YouTubeTV/SingletonLock which is preventing Discovery channels from working. I have the latest version of the image - 2023.0108.2341. I'm

I have used ssh in the past with the RPi but have since turned it off via the web UI.

My RSA keys in id_rsa/ have not been changed since 2019 but today when I turned on ssh via the web UI and copied my public key and tried to ssh into the RPi I just get a connection closed message.

I'm not sure what has changed. I am ssh'ing from a Mac and periodically update to the last macOS versions, but I can't imagine anything in ssh have changed.

I've also tried generating new keys with different algorithms, even the default, but still get a connection closed message. Also have tried connecting with dvr-server.local and IPv4 address.

I did add -v to ssh and see a debug message in the log:
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY

I did some searching but didn't find anything helpful related to that message.

Finally, because it's an external drive, I was hoping I could mount it on my Mac but unfortunately it can not "see" /mnt, only the /DVR partition.

My next step is to back up /DVR and start with a fresh install of CDVR but am hoping that I'm doing something silly that someone can point out. When I paste the public key I am pasting the whole string.

Thanks for any help!


It's possible RSA keys are not secure enough and being rejected now

Rebooting should be enough to fix the SingletonLock issue. That's not just a file it's usually an open OS flock

Thanks, I tried ssh from another computer and it worked. Not sure why I can ssh from my Mac anymore.

For whatever reason rebooting did not remove the file. Once sshed into the CDVR I was able to remove the file and could rescan Discovery. However, I'm getting auth errors on the other Discovery channels.


I wanted to circle back on the two issues that I've been having with the RPi 4 image.

I've managed to solve the SingletonLock issue. Rebooting alone did not fix it. I removed my sources that use Chrome - both YTTV and Pluto. After a reboot I added back both sources and the SingletonLock issue is gone.

However, I'm stumped on the ssh issue. I was able to ssh from a different computer using a rsa key, once. But now I am not able to anymore from any computer in the house. I've tried rsa, ecdsa and ed25519 and nothing works.

SSH is not too big a deal but I did use it to run the Pluto for Channels docker and if I ever need to update it then I'll need to reinstall the RPi 4 image.

IIRC, macOS changed which algorithms it would connect with, needing more secure ones than previously. I believe you can change your local SSH config to allow the less secure algorithms.

(I think so had to do this with a particular Ventura update.)