Stuttering on AppleTV4

After switching to a DS918+ I’ve noticed a stutter on any show that I watch via any method. Recording, movie, live tv or TVE. I’ve read so many threads where the DS918+ should handle Channels without a hitch. So I’m curious what I’m doing wrong. I saw this in my log on my ATV4

My ATV4 is wired. I’m running the stable version of Channels DVR from the App Store and the stable DVR version 2020.03.27.1730.

It’s not all the time. I mostly notice it when either skip a commercial or start up a new recording/live tv. Is my synology really the problem? I don’t see anything useful in the logs on my web admin page.

What is the audio driver set to in the app settings

Surround sound is on
Audio driver default

When you say a studder.... Your working during motion only or is it a constant studder? Any video of it?

Video and audio stutters typically the first 1-10 seconds of a show. And then on recorded content it will occur that the beginning again and sometimes during commercial skip. Hell sometimes just in the middle of a recording.

I’m a little more curious now....I do not have tuner sharing enabled and I am seeing the stuttering on my locals...

Also looked at another log from my appletv from a tve stream

I may have figured something out. I changed the audio settings in the ATV4 settings from auto to stereo only. I’ll continue to do some testing and report back

Ours is set to Dolby Digital 5.1 in the family room (WiFi connection) because that way the TV will do 5.1 pass-through to the digital optical output on the TV. In the computer room (Ethernet connection) it's set to Auto.

I've seen no stuttering with either live or recorded content. Both are ATV 4K's. DVR is hosted on a Synology DS218+.

1 Like

The only change in my environment was moving to the Synology as my DVR. I haven't noticed any skipping on other ATVs....then again I hardly use the others

Is the DS218+ perhaps connected to a different place in your network than whatever you were using before?

Have you tried going to http://atv.ip.add.ress:57000/speedtest with a browser (the Channels app has to be up on the ATV, but doesn't have to be doing anything) to check the performance between that ATV and your DVR? When I do that I get numbers like 995Mb/s download, 1-3 ms latency, 0.11-0.14 ms jitter. That's going through two NetGear ProSafe GigE switches.

Maybe try them more extensively so as to narrow-down the problem?

We have seen people encounter such things on wired networks, before, where the problem was the LAN switch.

Here's another thing you might look at on your Synology NAS:

[email protected]:~$ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:11:32:8E:76:9B  
      inet addr:172.16.1.2  Bcast:172.16.15.255  Mask:255.255.240.0
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:19640371577 errors:0 dropped:0 overruns:0 frame:0
      TX packets:6161615740 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:24005278017398 (21.8 TiB)  TX bytes:4264363648768 (3.8 TiB)
[email protected]:~$ uptime
 14:30:00 up 86 days,  3:20,  1 user,  load average: 0.00, 0.05, 0.09

You'll notice there are zero errors, dropped packets, overruns, etc. in 86 days of uptime, with 22TiB of data received and 4TiB sent.

2 Likes

I'll take a look at all of these and report back.

Speedtest

Download
100.16 Mbit/s

Latency
3.47 ms

Jitter
1.80 ms

I have tried testing this and I believe the test you are performing is between the PC you are typing the address into and the ATV itself...not the server and the ATV. I tried this test from my laptop via WIFI and Ethernet to find this out as I was only getting 600ish mbps via Wifi vs 940ish mbps via Ethernet.

I wish they added the speedtest function in the app.

Good stuff though.

Well I'll be damned: It is. That's kind of... not as useful as it could be. Time for an enhancement request, I guess. I had just assumed it was doing the same speed test as Android and Fire TV devices.

@scooter_scott: What did you use for running that speed test: A wired device, such as a computer, or a device on WiFi?

1 Like

Wired mac mini --> Netgear ProSafe switch --> Netgear ProSafe switch --> wired ATV4

So you have 2 switches? What are the connection speeds to each port?

I go wired LAPTOP-->Netgear Pro GS308T-->Asus ac88u-->wired ATV and I get 940ish mbps. Something in that path has a 100mbps link.

The ATV4 has a 100Mb link. All switches are gigabit ports.

1 Like

Ok, well, then, assuming your LAN isn't slammed with traffic and those NetGear ProSafe switches are GigE switches: Something ain't right. You should be seeing at least 80% of rated max bandwidth, not 10%.

Why does the ATV4 have only a 100mb/s link?

Oh that's right, the ATV4 non-4k is a 10/100 port.

Still shouldn't be an issue. My Sony TV only has a 10/100 port as well.

1 Like

Because Apple didn't put a gig port on it