Stuttering playback on Apple TV

Hi All,

Been running into issues on Apple TV lately when playing back recordings. It plays fine at first, Then after around 10 minutes of playback, All of a sudden the playback starts stuttering - As if it is buffering. I have to reboot the Apple TV to get it to work correctly again. Latest Apple TV App and latest server version. Live TV Playback works no problem with tuner sharing enabled. The Apple TV also does this on WIFI or Wired network connection.

This does not happen on any other device. Please advise as this is starting to get frustrating.

Does it show a spinner on screen when this happens?

Can you click Submit Diagnostics in the app after it happens then post here

1 Like

No Spinner on screen. Just stopping and starting of playback. Ill submit diagnostics later and let you know.

What model of Apple TV do you have? I have had some minor stuttering issues on my non-4K Apple TV. I’m wondering if the hardware may be struggling with 60fps de-interlacing. Might be worth trying to set it to 30fps and see if it helps. Changing that setting fixed the exact same issue in my iPad.

Issue just happened. All logs uploaded.

What is the duration of the recording you were playing when this happened?

The recording was 32 minutes long.

Would you be willing to try the latest DVR and tvOS betas to see if we can get to the bottom of this?

To update the DVR to the latest beta: Tap-and-hold on the Check for Updates button

To get the tvOS beta, from an iOS device go to https://getchannels.com/beta/ and join the TestFlight beta, then download the TestFlight app on your AppleTV and install the beta.

If this still happens in the latest betas I have a few option in the betas that we can try to see if it improves anything.

1 Like

Hi,

Sorry I have been away for two weeks with work. I don't really like using beta stuff on my live devices.

The stuttering seems to have got better but still happens. Both Apple TV and Server on latest versions. Any other help would be great. Further troubleshooting has resulted in a continuous ping from server to Apple TV running over night with no drop outs.

Not sure what other troubleshooting I can do as the issue is not present with Plex or Live TV (Tuner sharing enabled)

@eric Any update??

How do I get the Beta. The testflight app says I need to be invited and redeem a code.

I see you sent Diagnostic logs on the 11th. I don't see anything unusual in the logs.

Would you be able to take a video of what's happening?

To reiterate: this only happens on recordings? You have the quality set to Original? Can you re-submit diagnostic logs from it happening in the latest version? We released an update a week ago that had a lot of fixes in it.

Just happened again. Submitted logs from Apple TV again. Will grab the laptop and upload the video of it happening.

Link to video below:

https://www.icloud.com/iclouddrive/05-RiNTif_8SkJwk3UaeN-W0g#IMG_1665

Would is also help if I submitted server logs as well? Just in case there’s anything on there?

Our best guess is that you're having network issues. Are you able to plug your Apple TV into ethernet?

As mentioned previously. The issue exists on both WiFi and Ethernet. Currently the apple TV is wired in on Ethernet.

The studdering I see IMO it has something to do with 1080i interlacing. I see the studdering of people moving. The whole screen doesn't studder.

The whole playback stops and starts.

Another odd thing about it is that it can disappear for a few days and then the issue comes back.