Synology 218+ TVE Directv Now

I recently switched to using the Synology 218+ NAS and I'm now unable to pick see the Discovery Channel. I was able to do so running the TVE software on my Mac.

It's worth noting that when I was running the TVE software from my Mac, I was also able to pick up 120 channels (I'm grandfathered in with one of the original Directv Now plans). But with the NAS, I'm only picking up about 108.

Have you tried rescanning the missing the channels? Timeouts and trying to login to too many TVE providers can cause problems. Wait a couple of hours, then edit the source to rescan those missing channels.

(Also, the edit screen will give you what the specific error message was as a clue for why a channel is unavailable.)

To rescan: click the pencil icon under DTVN, then the Edit button on the top right. Scroll down to any channel missing a checkmark and click the button next to it.

Thank you for the response. I should have noted that I’ve tried rescanning repeatedly. That added one channel (giving me 108).

The odd thing is that rescanning on the OS X version consistently returns 120 channels.

Use the Edit button and rescan individual channels instead of using the Rescan All button. You can also compare the lists between your Mac and Synology. If there are error messages on channels you expect to receive, take a screenshot and email [email protected]

1 Like

Hi Tmm1,

Thank you for that. That's what was happening. I rescanned a bunch of individual channels and I'm now getting 122 channels on the NAS (more than I had been seeing on OS X).

Thanks again for your support through this. It is really appreciated!