Synology DSM7 and Philo no longer working

Note prior Philo tv everywhere initially worked after DSM OS 6.6xx to 7.0 but stopped working.
Philo add on no longer working with TV Everywhere BETA. Contacted Philo support and told Philo app doesn't support DSM7 OS on Synology. Per Philo support no timeframe for resolution.

Background on my situation:
Trying to add Philo to tv everywhere beta on channels DVR running on Synology DS420+ running DSM7 OS. Used to work on prior Synology DSM 6.6xxx but cannot add Philo since upgrading the Synology to DSM7 keep getting errors. Channels DVR was completely removed from Synology and reinstalled after the DSM 7.0 Upgrade using the Channels DVR 7.0 download.

Errors when trying to add Philo:

chrome failed to start: ./chromedp-shell: line 15: 2597 Segmentation fault (core dumped) "$loader" "$root/bin/true" 2> /dev/null ln: /var/packages/ChannelsDVR/target/channels-dvr/data/chromedp-chroot/headless-shell/swiftshader/.: cannot overwrite directory [0720/130242.842134:WARNING:resource_bundle.cc(419)] locale_file_path.empty() for locale [0720/130242.842435:FATAL:zygote_host_impl_linux.cc(117)] No usable sandbox! Update your kernel or see https://chromium.googlesource.com/chromium/src/+/master/docs/linux/suid_sandbox_development.md for more information on developing with the SUID sandbox. If you want to live dangerously and need an immediate workaround, you can try using --no-sandbox. #0 0x55e33df706e9 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2dba6e8) #1 0x55e33def34a3 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2d3d4a2) #2 0x55e33df00296 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2d4a295) #3 0x55e33cecb20e (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x1d1520d) #4 0x55e33de9d0df (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2ce70de) #5 0x55e33de9b52c (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2ce552b) #6 0x55e33de9b66c (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2ce566b) #7 0x55e33deebb24 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2d35b23) #8 0x55e33deeb838 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2d35837) #9 0x7fbcd9f94fca __libc_start_main #10 0x55e33baa7bfa _start Received signal 6 #0 0x55e33df706e9 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2dba6e8) #1 0x55e33def34a3 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2d3d4a2) #2 0x55e33df70291 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2dba290) #3 0x7fbcdaccbc20 (/usr/lib/libpthread-2.26.so+0x11c1f) #4 0x7fbcd9fa7fbf gsignal #5 0x7fbcd9fa9327 abort #6 0x55e33df6f225 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2db9224) #7 0x55e33df006fd (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2d4a6fc) #8 0x55e33cecb20e (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x1d1520d) #9 0x55e33de9d0df (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2ce70de) #10 0x55e33de9b52c (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2ce552b) #11 0x55e33de9b66c (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2ce566b) #12 0x55e33deebb24 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2d35b23) #13 0x55e33deeb838 (/volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x2d35837) #14 0x7fbcd9f94fca __libc_start_main #15 0x55e33baa7bfa _start r8: 0000000000000000 r9: 00007fff596648d0 r10: 0000000000000008 r11: 0000000000000246 r12: 00007fff59665bf8 r13: 00007fff59665bf0 r14: 00007fff59665be0 r15: 00007fff59665390 di: 0000000000000002 si: 00007fff596648d0 bp: 00007fff59664b10 bx: 0000000000000006 dx: 0000000000000000 ax: 0000000000000000 cx: 00007fbcd9fa7fbf sp: 00007fff59664948 ip: 00007fbcd9fa7fbf efl: 0000000000000246 cgf: 0000000000000033 erf: 0000000000000000 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000 [end of stack trace] Calling _exit(1). Core file will not be generated

You need to upgrade to prerelease and then click-and-hold the Sign In button after entering your login.

What should I upgrade to prerelease? I only see tv anywhere beta on the Synology.

On the DVR web UI, at the top under Status > Version, click the down arrow next to Check for Update and select Prerelease.

Thanks for the additional info. Updated to prerelease ( version 2021.07.28.0020) and I'm holding the sign in button in my email but I get an " context canceled" error. I tried it several times.

Click Add Source > TVE, select a random provider (not Philo), enter a random user/pass, then click and hold the Sign In Button.

Appreciate the additional direction but that approach didn't work. Same "content canceled" error, but it gave me an idea that worked.

Here is what worked: From Channels Web UI:

Click Add Source > TVE, select Philo, enter philo email address , then click and held the Sign In Button. While still holding the mouse sign in button used my cell phone to to sign into log in and confirm the Philo sign on. After the Philo sign on completes on the cell phone go back to the channel DVR UI (still holding the mouse button) and wait for the screen to sign into phio and start loading channels. Release the mouse button and let the channels add.

Thanks for the help.

1 Like