Synology NAS and Chrome Corruption Issue

I tried uninstalling and reinstalling channels on the server, but I can't access any of the TVE sources due to what appaears to be a corrupt install of chrome.

Also, submitted a log: cd740647-004d-41e6-9c79-8084258a4d38

Any suggestions on how to fix:

I couldn't find a way to delete the DVR folder in file station but delete all the subfolders before reinstalling but same problem.

After you install it and set your dvr directory and BEFORE adding a TVE source, update to latest prerelease ( Then run Troubleshooting and if it displays the same error, click the green image button. Then add your TVE source.

Chrome is not installed in your DVR directory in the shared folder where it records to.
It's in /volume1/@appstore/ChannelsDVR/channels-dvr/data

Thanks for the above suggestion. Here's the steps I've gone through:

  1. Uninstall
  2. Reinstall
  3. Upon entering into the webadmin, I see the following (my login and storage path are already setup upon initial entry after re-installing):

    4: I click Update (takes it up to 2023.11.29.1846)
    5: I go into Troubleshooting and it shows this (no need to update Chrome):
  4. I go into Setup and enter my FuboTV credentials and see the following:

  5. I go back into troubleshooting and now see this after clicking the Chrome Update:

It seems like it's either not registering Chrome as being corrupted after the install and update of the DVR. I'm assuming that uninstalling DVR from Package Center isn't removing the Chrome from the " /volume1/@appstore/ChannelsDVR/channels-dvr/data" folder?

Any other suggestion other than reinstalling Synology to clear out the corrupt version of Chrome?


Click here to upgrade Chrome

That will install Chrome v114 and should work.

@jator has TVE ever worked on this installation?

Yes, worked for about 6 months.

click the green image button.
That will install Chrome v114 and should work.

Okay, it looks like there's something going on with arm64 Synology systems that we'll have to investigate further.

Sorry, I should have been clear. I did click that and that's when I got the error I posted the screenshot that shows "Chrome failed to start". Will (semi) patiently await @eric's investigation.

@jator: Please update to the latest pre-release and then go to Settings -> Advanced and enable New TV Everywhere Embedded Chrome Launcher and try to scan again and then submit diagnostics. We'll see if that improves the situation at all.

It appears that our upgraded Chrome is having problems on some arm64 setups and working on others.

Still having same problem. Here's the log I ran after updating and re-running. 86f0ea96-59ac-4ea6-b086-fefe72742a42

Just an observation, my Intel based NAS is on Chrome Version 114 whereas the ARM64 is on version 117. No clue if that is causing the issue?

Those differences in versions have to do with the difference packaging of chromium that we use for different architectures.

Please update to the latest pre-release v2023.11.30.2037 on the ARM64 system and then try to run these commands one at a time, trying to scan between each of them and note if any of them succeeds.

curl -XPUT 'http://<dvr-ip>:8089/dvr/hacks/tve.chromium_tag/112'

curl -XPUT 'http://<dvr-ip>:8089/dvr/hacks/tve.chromium_tag/102'

curl -XPUT 'http://<dvr-ip>:8089/dvr/hacks/tve.chromium_tag/99'

When you are done, you can run the following to revert the setting:

curl -XDELETE 'http://<dvr-ip>:8089/dvr/hacks/tve.chromium_tag'

This build should resolve the issue with Synology ARM64 NAS systems having problem with TVE.

Thank you @jator for assisting with testing this out.

And this is why I love this software solution, so much appreciate the devs, and enjoy the community that has evolved within these forums.