The Windows firewall rule for Channels DVR is not enabled

I was trying to fix the fact that i couldnt connect out of the home and was following a post that said to delete channels dvr in the firewall settings and readd it. I did that and now i can not record or watch from my home and the setting pages says " The Windows firewall rule for Channels DVR is not enabled"

Any help appreciated

12_16_2018%20%2C%2012_27_41%20PM

Here's is an image of Windows Defender showing that I did indeed add it back in (I thought correctly) and I did restart the pc after adding it back to try that
12_16_2018%20%2C%2012_30_52%20PM

going to try to reinstall channels dvr as was suggested in another post i have found

**Update
After complete uninstall, reboot, reinstall it still says same firewall error

I have had that there for quite a while on my system and I see nothing affected by it. I just ignore it and I still get to stream outside the home no problem.

Having been testing it all day, after i played with dvr setting in the app on FireTv 4k it seems I can now record from inside my home and using my phone on cellaur only am able to access the system outside my wifi also. Frustrating seeing that message since in the future it might actually be needed to diagnosis.

This seems like a bug in the DVR when it tries to find the firewall rule. I will check it out

Thanks any additional information you need let me know - will be out of commission Dec 19-26 due to eye surgery but will check before and after that time.

I realize this is an old thread, but I have the same issue.

Running Windows 10 1909 with the Windows Firewall disabled.
I added Channels DVR to public and private but the warning message is still displayed.

Running version 2020.03.24.0127

i have the same issue and have had for several months. running version 2020.03.27.1730 on Windows 10 Pro 10.0.18362 Build 18362

I have this issue as well. Seem like everything works though, so must just be a bug.

So yea, bug is still there today...

Same error. Turning firewall off - still errors.

I have this issue -- sharing the HRHomeRun Tuner is the only thing that I can find that doesn't work, but I would like to clear the error. Reinstalling didn't help. Any suggestions?

Thanks,
Dave