Tried to delete and reinstall channels app on macOS, now says "the application channels can't be opened"

Hi.
Moved my channelsdvr to a different system, so the channels app on my Mac client didn't see the dvd recordings etc.
Didn't see a way to tell the app to go to a different IP address.
So, deleted the app from the /Applications directory and then redownloaded from the App Store.
But now trying to launch it gives the error that it can't be opened.
Any ideas how to fix this?
Thanks!

--Peter

Hmm no solutions?

1 Like

I changed the category on your post.
It is the iPad app running on a Mac, correct?

I don't use that, so can't help.

Should be Connect at Home and enter the IP address of your DVR server.

Hmm, probably the ipad app. It's whatever is in the macos app store called "channels".

It didn't ask me where to connect, so deleted and reinstalled, and now I get the error and the app won't start.

App Store is controlled by Apple. You can reach out to their support or try reinstalling again.

1 Like

This happens to me in Ventura with other apps from time to time, in my case, I reboot the Mac, and I can launch the affected app again. I think it’s a bug in Ventura. Maybe your issue is different, though.

Thanks for the idea but a reboot didn't fix it. Could re-re-boot I suppose :slight_smile:

Deleted Channels from /Applications, rebooted, reinstalled Channels from the App Store. Still get the same error.

Can you provide any screenshots of what the error looks like? This sounds like a macOS issue rather than an issue with Channels. Especially since it's the iPad app running on macOS via Apple Silicon. We don't' really have much we can do here, as this is all run by Apple and macOS.

Hmm, any chance this is occurring because I had the channels dvr running on this system before moving it to a different system? Could that affect the channels app trying to launch? Here is what I get from the console when searching for "channels" after trying to launch the app...

Try deleting that directory: com.getchannels.dvr

Hmm I don't spot it in /Library/Application Support nor ~/Library/Application Support?

Your screenshot shows /Library/Containers/com.getchannels.dvr

Ah. There is no com.getchannels.dvr in /Library/Containers

How about ~/Library/Containers/Channels?

Hey didn't know you could add system files to search. Nice!
Found the one you show and deleted it.
But still get the error trying to launch the channels app...

Hmm, just as a test, can you create a new macOS user account, log into it, and see if you're able to launch the Channels app there? That will help determine if the problem files are in ~/Library or /Library. Obviously the new "test" user can be deleted afterwards.

Another thing you can try, is signing up for the TestFlight and get the Beta version of the Channels app running instead. That's the app I use as my primary for Channels on the M1 Mac and it works well.

1 Like

I also just re-installed Channels (not beta) from the App Store, just to poke around and see what files it adds when you first configure it. I have a utility called Remove-It installed that keeps track.

At least on my system this is a (buried) folder it identified, I wonder if deleting it will allow you to start over fresh? Your subfolders will probably have different names but at least this will give you a place to look.

To be clear, what version of macOS are you running?

And you're trying to launch the client app on an M1 Mac:

...on the same Mac that is running the Channels DVR server, correct?

Interesting, thanks for the ideas.
Created a new account, channels launched fine there.
Joined the beta, it launches fine.
So problem solved, but not sure what caused it.

1 Like