Troubleshooting CC4C

I have followed the directions on this post to setup CC4C and I am having issues
(BETA: Chrome Capture for Channels - #130 by babsonnexus):

When downloading and installing it hit flags for malware etc. I was able to provide exemptions and remove it from quarantine. I put it in it's own folder on the C Drive. along with the .ps1 file making sure I used the correct path on the task scheduler and all troubleshooting that I can do.

When I open the .exe file on it's own. it opens then closes right away. there was a flash of script that comes up but it just flashes before closing the app. I was able to get a screen shot and this is what it says.

throw er; // Unhandled 'error' event

Error: listen EADDRINUSE: address already in use :::5589
at Server.setupListenHandle [as _listen2] (node:net:1422:16)
at listenIn Cluster (node:net:1470:12)
at Server.listen (node:net:1558:7)
at Function.listen (C:\snapshot\chrome-capture-for-channels\node_modules\express\lib\application.js:635:24)
at main (C:\snapshot\chrome-capture-for-channels\main.js)
at Object. (C:\snapshot\chrome-capture-for-channels\main.js)
at Module._compile (pkg/prelude/bootstrap.js:1926:22)
at Module._extensions..js (node:internal/modules/cjs/loader:1166:10)
at Module.load (node:internal/modules/cjs/loader:988:32)
at Module._load (node:internal/modules/cjs/loader:834:12)
Emitted 'error' event on Server instance at:
at emitErrorNT (node:net:1449:8)
at processTicksAndRejections (node:internal/process/task_queues:82:21)
at process.runNextTicks [as _tickCallback] (node:internal/process/task_queues:64:3)
at Function.runMain (pkg/prelude/bootstrap.js:1980:13)
at node:internal/main/run_main_module:17:47 {
errno: -4091,
syscall: 'listen',
address: '::',
port: 5589

Node.js v18.5.0

This is the code tht I captured that flashes before it closes but not every time. is there something I am missing to get this to work?

When restarting my computer as part of the troubleshooting it starts to run the task as it opens powershell but does nothing.

Looks like the port is in use. You might have to change the port

I have fixed it (kind of)

I copied my post into ChatGPT and it suggested
"The error message you've provided indicates that the address and port (5589) that CC4C is trying to use are already in use by another process. This can happen if there is another application or instance of CC4C already running on your computer, or if some other program is using the same port."

so I checked the task manager and the and found it way down as Node.js and ended it. I also went into my firewall and opened port 5589 for out going. and restarted the .exe and checked the localhost:5589 and it showed the right code.

I added the sources to utilize CC4C and it shows up and plays on the client.

after about 2 minutes of watching I get

:exclamation: Connection Lost
The connection to the tuner was lost. Press play to try again.

Not sure why I keep losing connection

1 Like

I have checked my logs. and I understand what is going on but have no idea how to fix it. I have added the channels for CC4C as directed using the computer that I have installed it for the IP address in the channel description i.e.

#EXTINF:-1 channel-id="NBC Local",NBC Local (KNSW)

for some reason the channel was pulling the NBC channel from my IPTV source (which is why it kept timing out) as this is a problem with my IPTV on every channel.

To solve the issue I removed the IPTV source

the feed was on on the client while I did this. It continued to play for about 5 minuted then I got the Connection lost. When I tried to restart the feed I get the Connection lost but allso
GET: not found

Premium - was the IPTV Source I deleted
15692 - was the NBC Channel

I do not understand why it was pulling from this source instead of the CC4C Source.

On the Computer that I installed CC4C I cannot access the program CC4C (This is not the same computer as the server as my server is an Nvidia Shield)

when I go to localhost:5589 i get
Chrome Capture for Channels

Usage: /stream?url=URL or /stream/


#EXTINF:-1 channel-id="windy",Windy

#EXTINF:-1 channel-id="weatherscan",Weatherscan

which is what is supposed to happen. but.. if I go to (The IP Address of the localhost) I get a connection timed out. To include trying to connect from my phone to this address.

Since I have never been able to open CC4C as a browser I have never signed into my credentials for DirecTV.

I then deleted the source of CC4C and re added it, restarted the client and now I get
Connection Lost (-17)
The connection to the tuner was lost press play again.

It seems the biggest problem is I cannot access the CC4C program that I have installed as it is not "capturing" anything

Sorry for the long post but I am lost

Update: I deleted the Node.js from the task manager and restarted the CC4C and it stayed open and says "[2023/11/05 23:06:05.974] Chrome Capture server listening on port 5589"
But it doesn't work on the client.

1 Like

Solved: It was a firewall issue: I had to put in the exception for port 5589.

Not sure Why the other issues were happening but it is working the way I want it.