I noticed when trying to watch a recorded episode from Monday (08/03) that the TVE feed from Buzzr (channel 6750) using my Philo credentials provides just a static image with the word "Fremantle" in cursive as the video stream. I checked the live stream, and saw the same image, no sound.

I refreshed the TVE source in settings, but still get the same result. I went to Buzzr's website, and was able to watch live there without any issues. Any ideas on what is wrong with this stream?

Channels numbered 6700 and above are free web streams that anyone can access, all without credentials.

This is a problem with the feed that serves that particular Buzzr stream, and has nothing to do with Philo.

Oh, I wasn't aware of the distinction. Updated the title and text of the OP to reflect that it's not specific to that TVE provider. Thanks!

This issue seemed to have been resolved a couple of days ago. However, now what is supposed to be Buzzr is now showing some Spanish language movie channel. I’ve refreshed the channel list, but that hasn’t helped. Is anyone else seeing this?

It is playing Password.

If you still have an issue, check their website to see what's playing

BUZZER works fine and the guide is accurate for me.

It seemed to resolve itself for me as well. Then it went to all blacked-out again yesterday. I am now experiencing the same issue as andersonchris. Checked their website, and it looks right, but through the DVR it's been infomercials and other random programming all day long.

Click and hold the Check for Update button on your dvr web UI

Couldn't resist
I think that's the one for BUZZR

That worked for me!

That fixed the problem. Thanks!