TVE CBS broken

Mine says:

Which is weird since it was definitely working 4 days ago. Absolutely watched plenty of football on it!

seems to be back up again

Do you have WPRI working again?

It looks like Channels uses to find the availability to stream.

I can't get any response other than {"success":false,"message":"USER_LOCATION"} no matter how I try and no matter what the location is. works just fine. I can't seem to stream CBS via Channels.

Logs at 12fe914d-182a-4460-af99-aa5c11025c24

What do you "what the location is"? Are you using some type of VPN or DNS service to spoof your location? Network websites maintain IP blacklists for VPN and VPS servers, so you may be falling into that group.

From my home connection, no VPN, no changes.

I do have VPN available but it's not in use right now.

If it was the VPN then I would expect not to be able to stream live from the live-tv URL.

No, but I'm not sure the problem isn't some agreement between Cox and CBSParamount/WPRI and nothing to do with Channels. The timing was just weird.

I have a good antenna setup so I pick up WPRI and WBZ no problem, but prefer TVE just in case. The other issue for me is my server is extremely underpowered, so HDHR stations in the web interface are a buffer nightmare (loading circles every 5 seconds). I spent a bunch of time playing with web player transcoding settings until I got something that seemed to work for everything (HDHR, TVE, XML) with very little buffering.

I am having this same problem again for the last day or so. CBS TVE will not play on Channels. It had been working fine for the last several months. I get this error in the logs:

2021/12/10 19:43:39.420759 [ERR] Failed to start stream for ch6003: TVE: get 400 Bad Request
2021/12/10 19:43:39.464602 [HLS] Couldn't generate stream playlist for ch6003-dANY-ip--1: TVE: get 400 Bad Request

Any idea how to solve this dilemma? Or is it just a CBS glitch that I have to live with?

I tried the links above to login to CBS streaming directly and got the above screen saying "Your TV provider is not yet supported in your location."

Have you tried this?
Make sure you update to the latest DVR pre-release version first.

If the cbs live streaming website won't allow you access, it probably won't work.

I just updated ChannelsDVR to the latest Pre-release version and am getting the same result.

Are you on a IPv6 connection to the Internet or IPv4?

I believe my server is on a IPv4 connection, at least my laptop is. I would have set them up the same a couple years ago. Like I said, it was working a couple days ago and has been for months.

OK. Then if you try to access the CBS Live website and it errors out saying your local station isn't available via your Provider, there's nothing Channels DVR can do.

How do you set up this secure connection? I tried adding "https://" to the start of the URL and it comes back with an error. Yet when I originally set up the TVE for my local stations months ago it worked perfectly with my non-secure connection. Now that I have messed with it trying to get CBS back I no longer have FOX or my local PBS stations either. All I get now is ABC and NBC.


I've been having this problem for a couple of weeks. Running Channels DVR on Raspberry Pi with YouTube TV as my provider. CBS Sports Network on channel 6196 is no longer available ("401 Unauthorized" message). And although CBS on channel 6003 appears to authenticate successfully, whenever I try to tune to this TVE channel my tuner ends up tuning to channel 2.1 on my HDHOMERUN (channel 2.1 is the WCBS channel in NYC). Basically, I have lost access to channels 6003 and 6196.

I have a feeling CBS broke this on their end. It was working with youtube tv. Then it stopped. Then it started working again. So then I changed my account over to a non-recoverable one and then I lost the channel totally after that. Just wouldn't authenticate. Not sure what they are doing. I don't think they do either.

I'm having the same issue now in the Washington DC metro on YouTubeTV. CBS not coming up in the channel search. I deleted the TVE source, logged in again, same issue. Logged in via the web, screen says YTTV not participating in my location, same as the screen shot earlier in this thread. Did anyone resolve?

Then you cannot get CBS on TVE. It is a contract situation between your local CBS and the Cable/OTT provider. You need to contact your local CBS affiliate to resolve this, but no promises that they will do anything.

I went round and round with NBC support folks and youtube TV. Basically the same issue you had 7rdr7. They didn't have a contract with the local station. But all the other stations they own I could connect to via their live website. Just not the local one. Ended up going with another provider which happens to have all 4 of my local stations. So that tells you how right babs is on this.