TVE Error for Directv

Please submit diagnostics

Just to make sure everyone's on the same page, are you using a recent/current pre-release? And if you are not running Channels in a container, is your Chrome/Chromium up-to-date?

If not, update both of those things first, then try again.

Looks like you're running in a Docker container and need to update to the latest tve container image.
2022/01/03 15:43:26.161247 [TVE] action=version product=Chrome/76.0.3805.2

If you go to Support>Troubleshooting in the DVR web UI, I would think it will tell you Chrome is out of date and give you a button to click to update Chrome.

If you're running it in the Synology package, you could try this

I am not getting any errors about it being out of date, also not 100% sure how to update it. I tried the suggestions that you put there, but they dont seem to work.

Submitted the diagnostic logs 5b34325b-3633-4016-9deb-701a210b530b

Are you running Channels DVR in the Synology package or in a Docker Container?

Synology Package

And you've updated your Channels DVR to the latest prerelease version 2022.01.03.2246?

Im actually on Version 2022.01.01.2223. I just updated to 2022.01.03.2246 and still getting the TypeError: Cannot read property 'click' of null in the logs

Hopefully the devs can see something in your diagnostics.
Running in the Synology package, the headless Chrome should be at version 89.0.4389.114

Are you sure your login is correct? Does it work on nbc.com/live ?

Yes it works fine there.. and it actually successfully works on some of the TVE channels, just get that error on a bunch of them. Here is how it looks. You can see I have access to some ( total of 95 I get ), but a bunch are screwed up

Not sure what they see in your diagnostics, but if it were me, here's what I would do.
Get your headless chrome updated following this procedure

To update chrome, you must click-and-hold the Sign In button:
click add source
select dish (or any other provider you don't have)
enter test/test for user/pass
click-AND-hold the Sign In button for one second

Once you do that you should see the following lines in your DVR log

registry.ping url=https://registry-1.docker.io/v2/
registry.manifest.get url=https://registry-1.docker.io/v2/chromedp/headless-shell/manifests/89.0.4389.114 repository=chromedp/headless-shell reference=89.0.4389.114
registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:1633fec4c8941cfbdde74459550ed95d255878d91ee08fb5894627cdf046fca0 repository=chromedp/headless-shell digest=sha256:1633fec4c8941cfbdde74459550ed95d255878d91ee08fb5894627cdf046fca0
registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:f04fd593031a9b736187fbfac2f8e72fbe68bc9d65ca2eaeedf9f618e255d658 repository=chromedp/headless-shell digest=sha256:f04fd593031a9b736187fbfac2f8e72fbe68bc9d65ca2eaeedf9f618e255d658
registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:71120124a9d579b544ff09506c59a81f5548dd2f19b278622307af04ef29e189 repository=chromedp/headless-shell digest=sha256:71120124a9d579b544ff09506c59a81f5548dd2f19b278622307af04ef29e189
registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:5af79d440e20791028323fc0d80605674d6442a23dc49909a362e9f94b22cae4 repository=chromedp/headless-shell digest=sha256:5af79d440e20791028323fc0d80605674d6442a23dc49909a362e9f94b22cae4
[TVE] action=error_response type=Other error=net::ERR_UNKNOWN_URL_SCHEME url= 
[TVE] action=version product=Chrome/89.0.4389.114 jsVersion=8.9.255.24 protocol=1.3 [email protected]

and your headless chrome should now be at version 89.0.4389.114

Next, use Update Password under the gear dropdown next to your source in the DVR web UI and just key in your existing Provider password to clear the chromedata folder.

Next, individually rescan channels with issues using Rescan Channels under the gear dropdown next to your source in the DVR web UI.

So I tried all of that, looks like chrome is up to date, but I still get the same error

2022/01/04 08:11:59.606402 [TVE] action=auth mvpd=DTV requestor=C-SPAN
2022/01/04 08:11:59.834239 [TVE] action=error_response type=Other error=net::ERR_UNKNOWN_URL_SCHEME url=
2022/01/04 08:11:59.836818 [TVE] action=version product=Chrome/89.0.4389.114 jsVersion=8.9.255.24 protocol=1.3 [email protected]
2022/01/04 08:11:59.837930 [TVE] action=navigate url=https://sp.auth.adobe.com/adobe-services/authenticate/saml?noflash=true&mso_id=DTV&requestor_id=C-SPAN&no_iframe=true&domain_name=adobe.com&redirect_url=https%3A%2F%2Fsp.auth.adobe.com%2Fadobe-services%2FcompletePassiveAuthentication
2022/01/04 08:11:59.839643 [TVE] action=request type=Document method=GET url=https://sp.auth.adobe.com/adobe-services/authenticate/saml
2022/01/04 08:12:00.152621 [TVE] action=wait_for_page
2022/01/04 08:12:00.186572 [TVE] action=request type=Document method=POST url=https://idp.dtvce.com/dtv-idp-authn/authn/v2
2022/01/04 08:12:00.186643 [TVE] action=auth_domain domain=idp.dtvce.com
2022/01/04 08:12:00.413412 [TVE] action=request type=Document method=GET url=https://oidc.idp.clogin.att.com/mga/sps/oauth/oauth20/authorize
2022/01/04 08:12:00.596617 [TVE] action=request type=Document method=GET url=https://signin.att.com/dynamic/iamLRR/LrrController
2022/01/04 08:12:08.458670 [TVE] action=page_ready
2022/01/04 08:12:08.458758 [TVE] action=wait_for_page done=true reason=page_ready
2022/01/04 08:12:08.458784 [TVE] action=fill_form u=XXXXXXX
2022/01/04 08:12:08.860759 [TVE] action=wait_for_auth
2022/01/04 08:12:08.879363 [TVE] action=request type=Document method=POST url=https://oidc.idp.clogin.att.com/mga/sps/authsvc
2022/01/04 08:12:09.007765 [TVE] action=request type=Document method=GET url=https://signin.att.com/dynamic/iamLRR/LrrController
2022/01/04 08:12:15.729644 [TVE] action=page_ready
2022/01/04 08:12:15.739885 [TVE] action=click_interstitial
2022/01/04 08:12:15.742322 [TVE] action=screenshot
2022/01/04 08:12:15.906634 [TVE] action=screenshot size=28463
2022/01/04 08:12:15.906978 [TVE] action=capture_html
2022/01/04 08:12:16.043001 [TVE] action=capture_html size=239935
2022/01/04 08:12:16.043749 [TVE] action=script_error err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught", LineNumber:12, ColumnNumber:43, ScriptID:"120", URL:"", StackTrace:(*runtime.StackTrace)(0xc001b4ef80), Exception:(*runtime.RemoteObject)(0xc000972480), ExecutionContextID:0, ExceptionMetaData:easyjson.RawMessage(nil)} exp=&runtime.RemoteObject{Type:"object", Subtype:"error", ClassName:"TypeError", Value:easyjson.RawMessage(nil), UnserializableValue:"", Description:"TypeError: Cannot read property 'click' of null\n at attApprove (tveinterhelper.js:13:44)\n at tveinterhelper.js:183:6\n at tveinterhelper.js:186:6", ObjectID:"-551582804540728070.6.5", Preview:(*runtime.ObjectPreview)(nil), CustomPreview:(*runtime.CustomPreview)(nil)} exp_value=TypeError: Cannot read property 'click' of null
at attApprove (tveinterhelper.js:13:44)
at tveinterhelper.js:183:6
at tveinterhelper.js:186:6

I went ahead and resubmitted the logs again once the update was made so you have a fresh set to look at.

a4a25e5e-e923-45f1-8817-a8ffec19c8ba

Hey everyone, just checking in to see if anyone had a chance to look at the logs I submitted to try and figure this out. If it takes time for this type of thing all good, just let me know

I don't know why it's not working for you.

Only thing I can suggest is to try it on a PC instead of NAS to see if there's any difference.

Is anyone else having an issue with FSTV / 6778 as I am getting this error:

2022/02/15 15:07:08.235354 [HLS] Couldn't generate stream playlist for ch6778-dANY-ip127.0.0.1: TVE: get https://edge.fstv-live-linear-video.top.comcast.net/Content/HLS_HLSv3/Live/channel(fc63b06d-0c6f-58c0-6c54-4176ba0c5c60)/master.m3u8: 404 Not Found
2022/02/15 15:07:08.235354 [HLS] Stopping transcoder session ch6778-dANY-ip127.0.0.1

Thanks

I just tried now and channel 6778 is working fine for me.

By the way, this is a free channel that doesn't require any subscription. You can go directly to their website to see if you can stream it there: 24/7 Livestream - Free Speech TV

For now, there is no separate package available in Channels for the free channels. You get them when you add your first source.

1 Like

It was fixed on v2022.02.15.2054. Thanks for checking though