tvOS 14.0b1

No observed issues with Channels app on ATV4K and tvOS14.0b1

1 Like

Food for thought, especially now that Apple OS beta season is upon us:

Previously, the Channels' developers have stated that they do not target OS versions still in beta. If they remain true to form, new tvOS/iOS/iPadOS features coming in the next major version release won't be addressed until after their official release.

(I'm not trying to be a "Debbie Downer", but rather trying to mitigate expectations, and to stem the flood of "I just saw this great new feature in the keynote address, why doesn't Channels do that yet" requests.)

1 Like

Understand their position (and agree with it) of not having to debug problems with BETA versions of tvOS and iOS/iPadOS and especially new Apple Features.

But some of us like to test the new BETA versions for completely other reasons and good to know that it does not break Channels. However, that does not mean that tvOS 14.0b2 would not break Channels. So, best to test on non production type use equipment. I personally have 8 Apple TV's where most are not used often so could test on one of those.

1 Like

Tried just now, It works. I'm interested to see how PiP works with Channels DVR app.

I'm guessing it won't because it will rely on the system video player, which Channels doesn't use.

2 Likes

I installed TVOS on 5 Apple TV’s in the house and they all worked just fine over several hour running simultaneously.

An aside, if you are using a HomeKit camera Channels does not have any issue running while the camera is in PIP.

But the cameras done take several hours to add streaming to HomeKit.

I was concerned that simultaneously running multiple 1080p might not be possible due to video processing limitations. But that appears to be a moot issue.