tvOS 14.5 and Channel Surfing (up and down)

Hi all, maybe this is a bug on my end or maybe it’ll end up being a heads up for others, but it’s something I thought was worth sharing. As of yesterday I’m running tvOS 14.5 Release Candidate (18L204) on two different AppleTVs. One is a 4K unit in the living room and the other is HD in the bedroom. The 4K unit is controlled by a Hub-based Harmony via Bluetooth, and the HD unit is controlled by an Infrared-based Harmony 650.

Everything was dialed in and working nicely. After applying this tvOS update to the AppleTV HD device I discovered I was no longer able to channel surf in Channels with live TV like I used to, with the channel up and down buttons on my remote. Those buttons do still work in the Channels grid guide, allowing me to scroll a page at a time instead of just one channel at a time. But they don’t do anything in live TV anymore. I then installed the same tvOS 14.5 on the 4K AppleTV, as a means to test, and discovered that channel surfing no longer works there either. The buttons work in the grid guide still, just don’t do anything while watching live TV. As mentioned that one’s on a different TV using a different remote control mechanism. So I’m wondering if this is a new issue with tvOS 14.5 that will soon affect many others and the public release is imminent. This was not an issue on the previous tvOS versions, I’d been using these same remotes to channel surf daily.

For what it’s worth I tried both the latest TestFlight of Channels as well as the public release in the App Store, and had the same results.

If this is something on my end only and it’s not affecting anyone else, I’d appreciate learning any more troubleshooting steps. I’ve rebooted every component that’s involved, and confirmed all of the settings are correct on the remote and Hub themselves, I just can’t channel surf anymore, and Channels’ ability to channel surf the “traditional” way was (for me at least) one of its biggest selling points.

I still love Channels very much, and I’ll adapt if this feature is no longer available, but I’d love to learn more to see if there’s any way to bring it back. Thanks for reading!

Maybe you can reprogram your Harmony. But the ATV remote still works great!

Huh? How do you change channels (up and down) while watching live TV (ie: “channel surfing”) using the ATV remote?

Reprogramming both Harmonies doesn’t seem like the correct answer here. Reprogram to what?

The page up/down issue with tvOS 14.5 should be fixed in the next TestFlight build.

1 Like

Thanks so much @tmm1. Much props to you and your quick magic. I remain in grateful awe.

1 Like

I can confirm that the latest TestFlight build immediately fixed the page up/down issue with tvOS 14.5 on my 4K AppleTV controlled by the Logitech Harmony Companion and Hub, set up via "Harmony Pro" Bluetooth profile. Hurray! Thanks again.

Unfortunately however the same update did not fix the issue on the other AppleTV controlled by a Harmony 650, which uses IR on a Sony TV with robust CEC support. Those buttons are assigned as "skip forward" and "skip back" on the AppleTV, and this used to work fine, prior to tvOS 14.5. I first learned it was supported via this thread:

Anything else I can try?

So are the skip commands going IR to the Apple TV? Or going to the TV and back over CEC?

Swipe down for quick guide.

Yes, thanks, I'm aware of that, but that's not the same as channel up + channel down, which is traditionally recognized and appreciated as "channel surfing."

I tried both ways, with IR commands to the AppleTV (skip forward + skip back, which is what worked before) as well as with commands to the Sony Bravia. The CEC support on this TV is good, I'm able to use a lot of its buttons for Channels support. But I tried both skip forward + skip back, as well as channel up + channel down, and neither of those worked, either.

I tried tvOS 14.5 with the Function101 remote and the up/down buttons are working on both the guide and the player.

1 Like

Thanks for checking. I've been testing, and see that channel surfing is indeed working again on my AppleTV with the (IR based) Harmony 650. This device is now on tvOS 14.6 (18L5546f.) Up/Down buttons have always worked in the guide, that's never broken. But what I've discovered is that channel surfing in the player using those same buttons occasionally stops working. What triggers it to stop working, I haven't figured out yet, but force-quitting the Channels Beta app (using the Siri Remote) and relaunching the app, allows channel surfing to work again. Until the next time I see that it's not working, in which case I have to force-quit and relaunch the app again.

I've figured it out and at least for me, it's completely reproducible, on both AppleTV's, BT and IR control. This channel surfing ability stops for me... after a PIP window appears, even just once. I'll toggle PIP (to go back to full-screen) and after that the Channel Up/Down buttons for my usual Chanel surfing don't do anything. These buttons only work again in that context after a force-quit and relaunch of the Channels app.

3 Likes

Thank you so much! I had the Sofabaton remote working perfectly and then channel UP/DOWN broke several months ago. Last night I was pleasantly surprised to find it working again. I'm too blind to read the guide from more than three feet away, so I tune until I find something interesting. So in a way, it's a nice accessibility option!

I can confirm this behavior as well. Channel Surfing breaks when PIP is activated. However, if you stop the playback in the PIP window, it does start working again.

For what it's worth... I am now on tvOS 14.7 on the same AppleTV boxes (one is the original 4K and the other is the newer 2021 model.) Both are using the new Siri remote though, with the new clickpad that encircles the touchpad. And I'm on the latest TesfFlight of the Channels Beta app.

Just saying that now, Channel Surfing no longer breaks when PIP is activated. I'm not sure if it's the remote or the software that fixed the issue for me, but it's been working fine for a couple of months now.