Ubuntu chromium snap error

I haven't had this issue happen since I installed Ubuntu on the Beelink I am now using.

I read through that thread as well and so far there are a few workarounds, but I hate having to do workarounds.

Can Chromium, or even Chrome be installed without using snapd? I don't personally care if it's in snapd or not.

But, like I said, so far I've not run into it again. If it does happen again it will most likely wait until it's trying to record something I really want to watch.

I moved over to docker ... I have other APPS that use XMLTV from Channels DVR and cannot afford this error it keeps popping up every other day.


sudo apt install chromium-browser

I have done that and after a reboot or after a day or 2 I get the snap error. I always use the command supplied in the linux Channels DVR doc.

apt-get install chromium-browser xvfb

Same here - that is the command I used when I installed it. sudo apt install chromium-browser

In my experience, snapd only causes problems. It should be taken out back behind the woodshed and shot.



Thanks that looks like it might be a solution great find. Ran the commands and will try again.

Edit everything Authenticated no snap errors.

1 Like

Awesome! I will give this a shot.

I think uninstalling snap killed Docker. SMH

Oops. I don't use Docker, so I guess I shouldn't have an issue there. I will have a play around with this tomorrow

I just re-installed docker it is working again.

This morning I just uninstalled chromium, purged it and then uninstalled snapd and purged it and then ran the "hold" setting on snapd. I then tested again by trying to install chromium again and did get the error that snapd was held back, so it didn't install.

I went back to Channels to verify the TVE channels wouldn't work but they still play fine. I then set a recording for Lone Star Law and it is recording just fine.

I then went in to verify I don't have Chrome installed and it doesn't find Chrome and I double checked that Chromium isn't installed.

How is this possible? Is there something else I am missing to check if one of these two browsers are installed or not?

I get that too but TVE has never worked better did a full rescan and everything authorized ....

The following information may help to resolve the situation:

The following packages have unmet dependencies:
 chromium-browser : PreDepends: snapd but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

1 Like

So you're saying that chromium isn't installed on your server as well but TVE is still working?

I get that same message when I put in sudo apt install chromium-browser - which is fine and what I wanted, just odd that TVE is working still.

It is working great even all the discovery channels that were having problems ...

Interesting. Ok then, I will keep it as it is since I didn't need a browser for anything else on this server. It is just for running Channels.

1 Like

Did you try fixing Chrome in troubleshooting on the web browser ?

I hadn't this time around but just did.


It's a mystery ... but it works. I still cannot find chrome on my server. SMH

OK So I am in the same boat. Last night I noticed that my TVE recordings didn't happen. I found this error when tuning a channel via TVE:
/system.slice/channels-dvr.service is not a snap cgroup

So I removed Chromium (and all dependencies) and then reinstalled. No go
Went to troubleshooting and Channels said my Chrome installation was corrupted. I clicked the button to fix. No go
Then I removed Chromium and tried to tune a TVE source. No go
Went to Troubleshooting and clicked the button to fix Chrome. FIXED, TVE works great now
SO after uninstalling Chromium TVE works.

Looked at the logs and it appears that Channels installed Chromium on its own???

The only thing that I changed on my end was I did an OS upgrade to 22.04.1 from 20.04 but TVE worked great for a week after that. I guess I am a bit confused here. @tmm1 do we need to not manually install Chromium anymore and just let Channels do it?

2022/12/15 00:41:18.705144 registry.ping url=https://registry-1.docker.io/v2/
2022/12/15 00:41:18.830224 registry.manifest.get url=https://registry-1.docker.io/v2/chromedp/headless-shell/manifests/97.0.4692.56 repository=chromedp/headless-shell reference=97.0.4692.56
2022/12/15 00:41:19.098832 registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:ffbb094f4f9e7c61d97c2b409f3e8154e2621a5074a0087d35f1849e665d0d34 repository=chromedp/headless-shell digest=sha256:ffbb094f4f9e7c61d97c2b409f3e8154e2621a5074a0087d35f1849e665d0d34
2022/12/15 00:41:19.828682 registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:9b14f784f92a19552c6301741f4299a599c5ddd79c4d2343f449baabc840079b repository=chromedp/headless-shell digest=sha256:9b14f784f92a19552c6301741f4299a599c5ddd79c4d2343f449baabc840079b
2022/12/15 00:41:20.061210 registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:a315ff4312e7298a86768350b0385281a5532eb1f8497f4680de8e3189a07894 repository=chromedp/headless-shell digest=sha256:a315ff4312e7298a86768350b0385281a5532eb1f8497f4680de8e3189a07894
2022/12/15 00:41:21.701222 registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:8a83912a086faffe21f33bc6cb5a881bcb61ff7a23d0b8bfa9198fe9ddb54dd9 repository=chromedp/headless-shell digest=sha256:8a83912a086faffe21f33bc6cb5a881bcb61ff7a23d0b8bfa9198fe9ddb54dd9