Ubuntu chromium snap error

This morning I just uninstalled chromium, purged it and then uninstalled snapd and purged it and then ran the "hold" setting on snapd. I then tested again by trying to install chromium again and did get the error that snapd was held back, so it didn't install.

I went back to Channels to verify the TVE channels wouldn't work but they still play fine. I then set a recording for Lone Star Law and it is recording just fine.

I then went in to verify I don't have Chrome installed and it doesn't find Chrome and I double checked that Chromium isn't installed.

How is this possible? Is there something else I am missing to check if one of these two browsers are installed or not?

I get that too but TVE has never worked better did a full rescan and everything authorized ....

The following information may help to resolve the situation:

The following packages have unmet dependencies:
 chromium-browser : PreDepends: snapd but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

1 Like

So you're saying that chromium isn't installed on your server as well but TVE is still working?

I get that same message when I put in sudo apt install chromium-browser - which is fine and what I wanted, just odd that TVE is working still.

It is working great even all the discovery channels that were having problems ...

Interesting. Ok then, I will keep it as it is since I didn't need a browser for anything else on this server. It is just for running Channels.

1 Like

Did you try fixing Chrome in troubleshooting on the web browser ?

I hadn't this time around but just did.


It's a mystery ... but it works. I still cannot find chrome on my server. SMH

OK So I am in the same boat. Last night I noticed that my TVE recordings didn't happen. I found this error when tuning a channel via TVE:
/system.slice/channels-dvr.service is not a snap cgroup

So I removed Chromium (and all dependencies) and then reinstalled. No go
Went to troubleshooting and Channels said my Chrome installation was corrupted. I clicked the button to fix. No go
Then I removed Chromium and tried to tune a TVE source. No go
Went to Troubleshooting and clicked the button to fix Chrome. FIXED, TVE works great now
SO after uninstalling Chromium TVE works.

Looked at the logs and it appears that Channels installed Chromium on its own???

The only thing that I changed on my end was I did an OS upgrade to 22.04.1 from 20.04 but TVE worked great for a week after that. I guess I am a bit confused here. @tmm1 do we need to not manually install Chromium anymore and just let Channels do it?

2022/12/15 00:41:18.705144 registry.ping url=https://registry-1.docker.io/v2/
2022/12/15 00:41:18.830224 registry.manifest.get url=https://registry-1.docker.io/v2/chromedp/headless-shell/manifests/97.0.4692.56 repository=chromedp/headless-shell reference=97.0.4692.56
2022/12/15 00:41:19.098832 registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:ffbb094f4f9e7c61d97c2b409f3e8154e2621a5074a0087d35f1849e665d0d34 repository=chromedp/headless-shell digest=sha256:ffbb094f4f9e7c61d97c2b409f3e8154e2621a5074a0087d35f1849e665d0d34
2022/12/15 00:41:19.828682 registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:9b14f784f92a19552c6301741f4299a599c5ddd79c4d2343f449baabc840079b repository=chromedp/headless-shell digest=sha256:9b14f784f92a19552c6301741f4299a599c5ddd79c4d2343f449baabc840079b
2022/12/15 00:41:20.061210 registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:a315ff4312e7298a86768350b0385281a5532eb1f8497f4680de8e3189a07894 repository=chromedp/headless-shell digest=sha256:a315ff4312e7298a86768350b0385281a5532eb1f8497f4680de8e3189a07894
2022/12/15 00:41:21.701222 registry.blob.download url=https://registry-1.docker.io/v2/chromedp/headless-shell/blobs/sha256:8a83912a086faffe21f33bc6cb5a881bcb61ff7a23d0b8bfa9198fe9ddb54dd9 repository=chromedp/headless-shell digest=sha256:8a83912a086faffe21f33bc6cb5a881bcb61ff7a23d0b8bfa9198fe9ddb54dd9

Channels will install chromium if not found on the system. Generally the system version is preferred, but seems like snap is not working reliably anymore. In the past the bundled chrome didn't work on Ubuntu so the system snap was required.


When Channels doesn't find Chromium installed, does Channels install an outdated version?

I ask because I'm using Ubuntu server, and I can get my YouTube TV login to work with TVE using the latest version of Chromium. However it only works until snapd updates or I reboot, then I get the snapd errors.

I can remove snapd and mark it on hold, which breaks the Chromium package that I installed, so I uninstall it too. Channels then installs a version of Chromium that works without snapd which is awesome- but YouTube TV doesn't work with it, giving this error-
":warning: Connection Lost- Blocked by Google: This browser or app may not be secure"

(When I reinstalled snapd and the latest Chromium, YTTV works again- until the snapd error shows.)

Since YTTV works with TVE on Ubuntu server with the latest Chromium until the snapd error shows, it has me wondering if the version Channels installs just needs an update. Thanks!

Had exactly the same issue. Disable snap and then uninstall chrome. Go back into channels web admin and run the troubleshooting. It will install chrome on its own and you will be good to go.

1 Like

I used the troubleshooting section to install chrome as well, but that version of chrome doesn't work with the YouTube TV login.

Which TVE provider are you using?

This what I get with YTTV and the channels installed chrome:

If I manually install the latest version of Chromium, YouTube TV login works fine until the snapd error shows. This is why im wondering if the Channels installed chrome needs an updated installer

Been running Channels DVR on Ubuntu Desktop 22.04 with YTTV under TVE for many months. Not a single problem. Install Chromium from Flathub

1 Like

You can see what version of chrome Channels DVR is using by looking at the DVR log.
2023/10/10 18:40:23.082150 [TVE] action=version product=Chrome/109.0.5414.74 jsVersion= protocol=1.3 revision=@e7c5703604daa9cc128ccf5a5d3e993513758913
2023/10/10 18:40:23.084050 [TVE] action=page_ready chromeVersion=109

1 Like

Good call, thank you. The logs show the channels installed Chrome is coming up on 2 years old:

[TVE] action=version product=Chrome/97.0.4692.56

I'll try the Flathub install. Thanks!

1 Like

That's why I moved my 4 Channels DVR servers to docker containers.
Had issues with v97. Docker container uses v109.

1 Like

Alright so the Flatpak install of Chromium doesn't run on Ubuntu server, and seems it's because Flathub apps don't work in a headless environment.

So I ended up skipping Chromium and installed Google Chrome browser instead, and it's working perfectly at the moment. Snapd is still disabled.

I installed it using the following commands:

sudo apt update
sudo apt install wget
wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
sudo apt install ./google-chrome-stable_current_
amd64.deb xvfb

And just like that, TVE works with YouTubeTV again :raised_hands:

Yeah, sorry about that. I forgot the devil in the details. It's not a server issue, it's the headless part -- either server or desktop. And, it's not all Flathub apps, only the ones that need to access the keyring. Same goes for Snap apps.

When you run headless, the password keyring is not unlocked unless you log in. The Flathub version of Chromium won't run until the password keyring is unlocked. The Snap version of Chromium doesn't need to access the password keyring so will run at boot. In my case I run CDVR under Ubuntu Desktop running headless/auto-login on a sub-$100 mini-pc. The mini-pc is dedicated to CDVR and not used for anything else so I took the password off the default keyring so the password keyring is unlocked at boot. The flathub version of Chromium will run at boot.

Thank you this worked for my new setup.

1 Like