Unable to add DirecTV as TV Everywhere Source?

I don't know specifically how to fix this but the developers constantly fix something for TVE almost on a daily basis. The fixes end up in the latest pre-release.

So the first thing I want to make sure of is that you are using the latest pre-release.

Please confirm which version of Channels DVR you are using.

Does it work on nbc.com/live with your login?

I had the same issue last week. I had to do several things to get it fixed. Open Chrome on your server and make sure that all privacy settings are off, no 2 factor, no blocking of any kind. Log into nbc and authenticate for Directv,and start a stream.

Open an incognito window in Chrome and log into Channels server and then add Directv as a TVE. It may take several scans to get all the channels and some channels may need manual rescans under the manage lineup menu. I eventually got 192 channels.


Thank you so much for the suggestions. Sorry for my delayed reply, I hit some speed bumps along the way and want to be as thorough as possible with my answers.

When first asking I was using "2022.10.17.2159." Then I checked for latest pre-release, which downloaded and installed. But unfortunately this also crashed the DVR server. At least, it made it inaccessible to me. After this update I was unable to connect via the web page at all, even after a long time of waiting. So I went to the Windows PC where Channels DVR is installed. I couldn't access the web page on that computer, either. And so I launched the Channels DVR installer to try and stop (or start?) the server again but clicking that button didn't do anything, either. I ultimately just rebooted the whole PC and then when Windows loaded and I clicked the Channels DVR icon in the task bar, I was able to get back into the web site for it. Phew! And thankfully everything was running fine, and has been updated to the latest pre-release.

After this, I tried to add DirecTV again via TVE but unfortunately got the same error as before. I do understand though, the pre-release updating schedule is key for stuff like TVE.

Thanks for this advice too. I went into Chrome's privacy settings and basically, did the opposite of everything I've learned over the years when it comes to IT and security. I allowed all cookies, turned off all "safe browsing" protection, turned off secure DNS, allowed any and all pop-ups, set permissions for everything to "ask" or "allow," but never block. It all felt very dangerous and exciting, lol.

Alas this didn't do the trick for me either. Even after doing all of that I still couldn't add DirecTV to my Channels DVR setup via TVE. Same error as before.

This question helped me narrow it down a bit, so thanks for this too. No, I can't seem to log into that page with my DirecTV credentials. When I try, the web page just flashes, I see an interstitial black page with some white text that mentions adobe, and then when the page refreshes I'm brought right back to the previous page (and I'm not logged in.). So I gather this is at the core of the issue, if I can't log in here I won't be able to log in via Channels DVR either.

Just for comparison's sake I tried in Microsoft Edge instead of Chrome on the nbc.com/live page and saw the exact same behavior. For the record I have no ad-blockers on my system, no browser extensions at all. And this is on a newly configured PC server purchased from Dell with Windows this month. It's a new and clean system, there's nothing installed on it other than FileMaker Server and Channels DVR Server. And I have full admin privileges, I'm the only person using this box. So now my question is, why can't I log in? My same credentials work fine when I use them at directv.com.

As far as this page goes though, I was wondering what else could be different, why can't I log in and authorize? I assume it needs permission for location tracking, and I granted that inside Chrome's privacy settings, but maybe that wasn't enough. And so I looked into location services on Windows itself, and see it is off, and I an unable to "change" that - the button does nothing.

My situation is exactly described here by someone else in 2019: Redirecting

Sadly there is no resolution offered there. And I agree with the last comment that a whole Windows reset over this issue would take too much effort and time. And is this Windows level of location tracking even related to that web page? Or are the location permissions in Chrome handled distinctly separate from that? I'm thinking it's the latter because also for comparison's sake I signed into YouTube TV and Fubo TV, and was able to add them both to Channels DVR, no problem. Surely those check for location as well?

Not sure what else to try at this point, but hopefully these details help others in some way. If anyone has other advice I'm all ears. And thank you for your time.

Can you log into your Directv account page? I have found that too many failed attempts on Channels tends to lockout my DTV account until I reauthenticate and set a new password.

From experience, I have found that DirectTv forces you to change your password every so often...it's either 60 or 90 days I think..try logging into your DirecTv account and changing it...then use that to login on TVE.


That's a good point about changing the password.

I had to do it at one point when I was also having issues with my DirecTV source in Channels.
Changing my DirecTV account password and updating Channels did it for me at that time.

I have had a direct tv tve login for 5yrs now not had to change password once.

Not a DirectTV user but I was unable to add TVE with Xfinity and all of the troubleshooting steps failed. Finally changed my password and was able to load TVE as a source. So in my experience, it's worth a shot.

I'm glad it worked for you!


OK great idea, thanks, I will try a password reset when I'm back at the house and have time to troubleshoot this. Should be by the end of the week. Hopefully it works and I'll report back here. I appreciate all of your feedback and advice!

I found some time to troubleshoot some more and share my findings here. First, I updated to the latest pre-release of Channels DVR again, and unfortunately, the same thing happened, I lost access to the Channels DVR web page afterwards. The Channels DVR installer was also inoperable. Same as before:

So I had to reboot again. This time, when I opened the Channels DVR installer, for the first time, I saw the button to "Run Channels DVR as a background task" (or something to that effect.). Once I enabled that, I noted I was able to get access to web page and continue on. Hopefully now that that's enabled, future updates to the prerelease will proceed smoothly without losing access to the web page. But I wanted to mention this, as I'm a new user installing this on Windows and hadn't seen that mention of the "background task" being required for ongoing usage.

After this, I confirmed I could log into directv.com on the web using my credentials. Under "account info" I saw my email address wasn't "verified" so I followed the steps to get my email address verified. Once that was complete I tried to add DirecTV to Channels DVR via TVE, but unfortunately got the same "authn: 401 : Data not found" error I've been dealing with. I then changed my password on the DirecTV site, and returned to Channels DVR to try again, with the new password. Unfortunately again, I got the same error.

Lastly I went to nbc.com/live to test my login. And I'm having the same issue as before, I click the DirecTV logo, the web page just flashes, I see an interstitial black page with some white text in the upper left corner that mentions adobe, and then when the page refreshes I'm brought right back to the previous page with all the TV provider options (and I'm not logged in.). If I click any other option, like Xfinity, Spectrum, Optimum, they all bring me to a log in page. Only DirecTV stands out, as the one that doesn't actually present to me a login page.

This happens in both Chrome and Edge, and I made sure to reset both browsers completely and remove all cache and cookies. This Windows server box is also brand new, I haven't installed any firewalls or ad-blockers that might be interfering here.

I'm at a loss where or how to continue, might just have to move on with a different TV provider or DVR solution. I've learned a lot and appreciate it. Thanks all for reading and trying to help!

Sure sounds like you have some kind of dns filtering happening

1 Like

You could try opening the developer console and see if there are errors there. Might show you which servers are being affected by DNS issues. What DNS settings do you have on your home router?

Have you tested your login at other network sites to see if it behaves the same as at NBC?

This definitely seems to point to problems with DirecTV's authentication backend.

1 Like

I lost authentication on all DTV channels last night. Took hours to get them back. Could only authorize 3 channels at a time before it would fail. Even then each channel can take almost a minute to authorize.

Maybe, I'm not sure. Sure seems strange though, I still haven't figured out how to fix it.

Unfortunately I'm not familiar with the developer console or how to interpret it. But I was able to check my DNS settings, the home router was using the DNS from my internet provider (Frontier.). But I changed it to Google's DNS and also tried with OpenDNS, and neither made a difference. The next time I'm at the server I will look more closely at the developer console and see if I can make any heads or tails from it.

Yes I tested at ABC.com and was able to watch live TV there with my DirecTV credentials. It's at NBC.com/live where I have this problem. And also with Channels DVR's web administration page.

Probably? Not sure if this will help, but here's a video of what I've been experiencing:

This happens in both Chrome and Edge, and I made sure to reset both browsers completely, and removed all cache and cookies. I've also tried in Incognito mode. This Windows server box is also brand new. As mentioned above I haven't installed any firewalls or ad-blockers that might be interfering here. And yet I can't even get the necessary login page to display.

1 Like

This just started happening for me as well. I sent in my logs and emailed for help.

An update on my situation, but I was for some reason able to fix this by switching from using DirecTV Stream to just DirecTV as my TVE provider. I don't have any dishes and just access DirectTV Stream on the web/apps, but this totally works for me.

I do have a strange account since I used to work at an AT&T company and signed up with an employee discount so maybe that is causing weirdness, but it was working totally fine until recently.