Unable to get Bluey or M.A.S.H. to show match

I am unable to get Bluey or M.A.S.H. to show match, and there isn't any way I have found to manually match these shows with Gracenote or TVDB within Channels.

With other apps, I can use an IMDB Series ID or other means to manually correct issues.

I have double-checked my files with FileBot, and I have tried to edit the metadata listing in Channels for each (including adding and removing punctuation for M.A.S.H., as well as correctly entering the series release date, etc).

For M*A*S*H, try entering the tmsId SH000027100000
zap2it M*A*S*H

If you enter Bluey in the search box at zap2it, it displays 7 different versions.
What I do in cases like that is right click each one and open in new browser tab.
Then when you find the correct one, get the tmsId from the url of that web page (tmsId=).

Oh... thank you. I didn't know the Zap2it trick, but using these ID's resolved the match issue.

In the meantime, hopefully Channels devs pick up on these missing ones and correct the database...

Channels doesn't control the database. TV show data comes from Gracenote (who also provides the data for Zap2It, which is why looking it up on that site can help you find the IDs).

I should say 'correct the functionality' to allow for both manual correction, and multi-source matching

Not sure what the problem with M*A*S*H is other than entering the show title incorrectly

Try it… it’s a good test. I tried “Mash”, which produced quite a few results. But none of them were correct. I then tried “M.A.S.H.” and “M.A.S.H”, which produced no results. :face_with_spiral_eyes:

As for the possibility of an asterisk - it’s a wildcard symbol that gets removed by metadata editors and would not be used. Windows also does not allow the use of an asterisk in a file name…

How do you know the devs didn't do something clever here and replaced * with something like %2A (as in urlencode)?
I scheduled M*A*S*H and it will record 2 hrs from now. I am using Windows as my server for the next few days.

The thread is actually about matching the show title with the series, and the issues I encountered. There's no doubt this particular title would need to be handled in a unique way because of its asterisks. But the other example, Bluey, was very straightforward and should have easily matched.

M*A*S*H is recording w/o any issues on a Windows DVR. The clever thing the DVR does about * in the name is removing it.

Has nothing to do with a search in the Fix incorrect match for imports.

While that may be true for the filenames (but maybe not ... I haven't tried with an * in a filename), in the "Fix Incorrect Match" dialog, inputting M*A*S*H brings up "M*A*S*H (1972)" as the first match.

I thought...so should MASH... but I get it - the database resides outside of Channels. It's just an unfortunate limitation that an exact match was required to correctly match the series.

This thread can be closed. I definitely learned and appreciate that I can cross-check against Zap2it. Thanks all.

You are finally onto something once you started spelling the show title correctly. :wink:
While the database resides outside of Channels, the searchable index to locate shows is local and there is no reason it couldn't contain a human friendly version of the show title, so both MASH and M*A*S*H could match.
I can not guarantee what the developers reaction to this suggestion is going to be. I am betting on this thread being promptly closed. :rofl:

Thanks for the feedback.