Unable to install on Synology DS918

I am attempting to install Channels DVR onSynology DS918+. I did the following:

  • Installed the Channels Synology package on the NAS
  • I can not the Channels DVR admin screen at http://[Synology IP]:8089/admin/settings
  • Changed my router to forward port 8089 to the NAS

The admin screen screen will not display. Its there another version or something else I need to do for the Synology?

Did you start the package from the Synology Package Center after you installed it?

what package from the synolgoy package center do I need to install?

yes, it say it is running,

You said you installed the Channels DVR package.
Look in the Synology Package Center and see if it's running.
If not, start it.

What happens when you click on OPEN?
Screenshot_2020-07-25 DS1019PLUS - Synology DiskStation

It takes me to the admin address, and nothing displays on the page.

May have crashed, or something is blocking you from accessing it.
Try going here http://1.2.3.4:8089/log
where 1.2.3.4 is the ip address of your nas
this will let you view the Channels log
If it doesn't respond, go to the Synology Package Center and Stop, then Start the package.

Nothing comes up. It can't be the port. I installed on my MAC, and it worked. Just won't work on the sinology

go to the Synology Package Center and Stop, then Start the package.

Did you download the package from here?

yes. I downloaded it from the site.

That didn't work.

If stopping and restarting the package doesn't work, and nothing is blocking your web browser from accessing it, I don't know.

You are attempting to view the admin page from the same network as the NAS, right?

Yes. I am on the same netowrk.

Maybe a browser add on blocking scripts or something?
Mine works from any browser I try, Edge, Firefox, Safari, Chrome.

I have tried that. I also tried using my windows computer. It is something with this Synology NAS.

I'm out of ideas. Unless you have something blocking in the Synology Firewall. One of the devs may ask you to ssh into the synology to check things.

Another idea.
Have you installed any other packages that might be listening on port 8089?
If you ssh in to the Synology and run the following command it will show what's listening on port 8089

sudo netstat -pane | grep :8089
tcp6       0      0 :::8089                 :::*                    LISTEN      0          1736594    14366/../latest/cha

at the end of the line is the process id for channels-dvr in my case
14366/../latest/cha

sudo ps -eF | grep channels-dvr
root     14366     1  1 646768 168320 0 Jul21 ?        01:13:37 ../latest/channels-dvr
1 Like

This is what it said. I don't understand how to read it.

[email protected]:~$ sudo netstat -pane | grep :8089
Password:
tcp6 0 0 :::8089 :::* LISTEN 0 998726 24051/../latest/cha
[email protected]:~$