Uninstall DVR Wake Helper


#1

I tried installing the wake helper to my services.

I understand about how it works and checked with
pmset -g sched
I would really like to know how to REMOVE or uninstall the helper program WITHOUT removing the whole DVR server service. There’s no option to remove in the menu.

I apologize if this violates any rules. I searched and could not find a topic covering this.


#2

To remove the helper, open Terminal.app and run:

sudo rm /etc/sudoers.d/channels-dvr


#3

Just so I am clear, this removes the HELPER but NOT the whole Channels dvr server that starts on login right? I still want the dvr server itself to start when logged in.

The channels dvr server and my OS will just go back to before I installed the helper with that osascript prompt?


#4

Correct


#5

Can you elaborate on why you want to disable it? Is it not working correctly?

Maybe I can make it a check toggle in the menu bar, but there should be no reason to turn it off.


#6

Well, it’s unoptimal for my workflow. I keep my mac on as I use it. However there are times I need to turn it off and don’t like it turning on by itself. When I turn it off, I need it to STAY off. My computer room is near a laundry room, this can cause my desk to rattle so I keep it OFF on laundry day because I don’t want to risk hard disk corruption or damage. Besides, I’m uncomfortable without the security of knowing that when my mac has been shut down or powered on. It’s because I knowingly did so.

Besides, I still need to log on manually, so the power on function doesn’t actually solve the issue it attempts to solve for the people that want this feature but aren’t running it on a dedicated machine. However, I’d prefer that issue not be solved as overriding log in is even worse, security wise.

As for when I keep it on, I just have it on the screensaver if I am using the DVR.

I understand this helper is useful for some, especially those with laptops. I am not one of those people. So yes, I’d really appreciate a toggle for it.


#7

I just followed your instructions but the scheduled events on
pmset -g sched
Still show up. How do I remove these?

Note: Edited post due to stupid autocorrect.


#8

sudo pmset schedule cancelall


#9

Okay, thank you for all the help. You’re really responsive.

Part of this is I am planning on switching to a shield and a ubuntu PC soon. However, I love this interface and am really happy my setup can stay the same even off of Apple’s hardware.

I really look forward to the future development.

Off topic thing though: For AppleTV users (including myself), we have gotten frustrated about the lack of multitasking persistence. It’s the only App on AppleTV that reloads (loosing our buffer) all the time. That and the “double click play to switch to random channel”?

Sorry about the small complaints. I just figured they were small enough to just say something while we were talking. Otherwise, I REALLY love what you guys have been doing and have been a happy user.


#10

I agree this sucks, but it’s a limitation of tvOS. Our app cannot run in the background, and if we can’t stay running we can’t keep an open connection to the HDHR to continue buffering. Switching apps should work fine while watching recordings.

Double clicking play takes you to the previous channel. Are you experiencing bugs with it?


#11

Double clicking play takes you to the previous channel. Are you experiencing bugs with it?

I am unsure…? We’ve never really had a thing where we need to go to “the previous” channel. There’s two main use cases here that makes this channel switch seem random

  • We’ve navigated to a channel directly from Home > Channels App > Guide > Selecting channel.
  • We’re watching a recording from Home > Channels App > Recordings > Playing recording.

More often than not, it’s frustrating because we will click the “play/pause” button twice, once to pause as someone is saying something and then again to resume. I guess it seems like this feature allows for a VERY long time between presses to consider a “double click”. I wonder if it’s related to the oversensitivity of the trackpad when seeking as well. In “Computers” or playing iTunes content, the seeking on the trackpad is MUCH more controllable than on channels.


#12

Has this changed with recent installs? I get:

rm: /etc/sudoers.d/channels-dvr: No such file or directory


#13

It's the same. That means it wasn't installed or got deleted when you upgraded macOS


#14

Thanks. Weird, I didn't get an error message when first installing the auto-wake helper.