Vanishing virtual channel

This morning my virtual channels are disappeared from my Apple TV. (I submitted diagnostics after a fresh load of the latest beta client.)

The channel displays in the webUI, as well as in my Android clients. However for some reason the channel will not display in the guide on the Apple TV. I'm not sure what else can be done to get it to display, as I've futzed with the guide database, restarting the server and client, as well as toggled the virtual channels from within the Manage Sources menu.

Has anyone else encountered this?

Are they missing under settings > Manage sources ?

Virtual channels as a collective are listed, but not enumerated individually. And they are enabled; I even tried toggling them from within that menu.

Could be a invalid character in one of the names or image urls

That's possible, but the virtual channel hasn't changed since it was added quite some time ago. And it's the entire entry in the guide for the channel that isn't present, not that it isn't populated with entries. The guide isn't listing the channel at all.

Logs from forcing a refresh, and the client fresh start:

2022/01/23 11:27:29.401563 [IDX] Pruned 3 expired airings from X-VIRTUAL in 2.784214ms.
2022/01/23 11:27:34.588841 [DVR] Indexed 1 channels (255 airings + 0 replaced) into X-VIRTUAL [0s index]
...
2022/01/23 11:32:15.464187 New diagnostic log submitted under d71eb247-1f60-459b-a6be-a2e3923cecc1

I removed both release and beta versions, then reinstalled. After a fresh start, the virtual channels are back. I'm not sure where things got mucked up, but going nuclear fixed it up.

I'm calling this fixed and solved.