Video freeze w/ OG HomePods

Just submitted diagnostics from my iOS device immediately after attempting to play back content. The video does not playback, just a still image displayed but audio track can be heard as normal. This occurs on OTA and local content.

This is using the latest beta version 12.2.1838

This started recently?

Is there any difference if you change drivers under Settings > Playback > Advanced ?

Started on beta 12.2.1520. Works perfectly using the latest general release. My setup in channels is Deinterlacer: Experimental - Video Driver: Experimental - Audio Driver: Default. I have found this combination works perfectly for me. I use paired OG HomePods and find the experimental audio driver to still be glitchy.

Apologies, the diagnostics submitted were from my iOS device. That was using default audio, video, linear drivers. I changed those to experimental and that solved the issue.

However, my ATV still has the same issue on the release 12.2.1838 and is using experimental drivers on video, deinterlacer, but not audio.

I just submitted diagnostics from my ATV.

1 Like

Just changed audio driver to experimental and that has resolved the issue. However I notice that the initial video frame sticks for a second, then catches up with audio and continuous to play.

It’s like the frame stick remains stuck if using the audio driver.

Ultimately, the performance and experience is much better on the general release, using default audio driver, than the beta release that now has to use the experimental audio driver.

I see one issue in the default driver. Will fix it shortly.

The other thing is that you're trying to play a file with dolby atmos, and these latest builds use a new experimental driver that passes through atmos directly. Previously neither driver was passing through atmos object metadata. Only the experimental driver is capable of doing so.

Is the frame stuck issue you're seeing with exp audio happening on both atmos and non-atmos files?

What kind of glitches are you still experiencing on non-atmos files with the latest build and exp driver?

Also when you refer to general release build, are you using v5.1.0 or v5.1.1 ?

The frame sticking issue when using the default audio driver occurs on any content, even OTA content that does not contain Dolby atmos. The general release I am using is 5.1.1

1 Like

If you quit/restart the app (click TV/Home on the siri remote twice and swipe up), then play OTA with default does it still stick?

Yes, I always force quit the app when switching between general and beta release.

Just submitted another diagnostic from ATV, force quit the app, then immediately selected an OTA channel without Dolby atmos. Video frame stuck permanently with continuous audio. Using default audio driver. This is on the latest beta, as advised no issues on 5.1.1 general release.

Ok cheers. I am trying the last beta with default audio and also seeing the stuck video problem.

1 Like

Seems to only happen with airplay.

Seems to only affect the first playback session after an app restart. If you exit and play again, it does not get stuck. Can you confirm?

I’m experiencing the issue all the time, even after an immediate app restart using force quit. Tried multiple times but consistent behaviour of frame sticking.

Sadly version v2021.12.02.2032 has not resolved this issue.

Should be fixed in this build. Please confirm.

That’s fixed the issue. Many thanks.