Web player buffering w/hardware transcoding

I am new to the Channels application and have just installed the server on docker in both Debian and Unraid and the web player is heavily buffering and unwatchable when hardware transcoding is selected on HD channels. The android app works fine w/hardware transcoding enabled. When switched to software transcoding, the web player plays w/o issue. I get the same results on Windows Chrome and Edge chromium If there was a Windows client I wouldn't care. :wink:

Also, Plex installed is installed on docker on the same box and is able to utilize hardware transcoding w/o issue, making me think the host is configured correctly.

I have no idea how to troubleshoot this. Can somebody please give me some clues?


The android app doesn't use transcoding by default. Did you explicitly change the settings for streaming quality inside the app

What are the OS/CPU details as shown on dvr web UI?


Dell Inc. Precision Tower 3420
Linux Alpine
3.10.3 (kernel: 4.19.107-Unraid)


8 cores / Intel(R) Xeon(R) CPU E3-1245 v5 @ 3.50GHz

load averages: 1.22 1.32 0.83


31.38 GB
98.7% free

Hmm, I had a black screen when the android app was sent to "Hardware." It plays well w/ the "Hybrid" option. While the server is set to "Hardware."

The setting in the app you're referring to is the Decoder. That's different from the Transcoder/Encoder on the server.

Anyway it sounds like there's some hardware transcoding bug, maybe specific to that CPU. It's surprising Plex works without an issue.

We can look into this but your best bet for now will be to stick with Software encoding. Can you click Support > Submit Diagnostics from your DVR web UI.

Logs have been submitted as f3983cba-0b8e-4829-9f22-9901a8a4472c


Ok, I changed the Streaming Quality-Internet Streaming on the Android app to 720p. It played OK w/the server transcoder set to "Hardware"

Is Internet checked or Home?

Oops, that was a bad test...sorry...still learning. I re-tested with "Home Streaming" checked and set to 720p. This time, the playback was heavily buffering and unwatchable.

Okay good so the behavior is the same everywhere when HW is enabled.

Try click-and-hold on the Check for Update button. After the upgrade see if web player shows any improvement.

You can also try the "old transcoder" checkbox under the experimental settings on the web UI.

OK, I upgraded to Version 2020.07.30.2221 but that did not help. Also, the "old transcoder" did not help. :frowning: