WHS2011: Channels DVR doesn't auto restart after reboot


#1

I run Channels DVR on a headless WHS2011 machine and its been working fine. However I recently noticed that it had stopped working. Upon investigation I noticed that the server had applied a windows update and had rebooted. I would appear that the Channels DVR did not start again after the reboot (automatic login is disabled on the server for security reasons). When I log into server via RDP Chanels DVD then starts working again.

I want to configure the server to start Channels DVR automatically after a reboot. I seem to remember that Channels DVR now runs as as a service. I tried searching for the service that it was running under but could not find it; there's no "Channels DVR" in the "Services" list.

How can I configure it so Channels DVR starts automatically without a user logging in?

I tried to run the installer again, to see if this was the problem. The installer seems to show that the DVR Engine was running. So I stopped the DVR Engine in the installer and reinstalled the program. This lost all my TV schedules so I tried to reinstate a backup. To do this I had to untick the DVR box in the web interface settings which then gave me this error (latest version of Chrome on Windows 10)

I then went back to the reinstate the backup and I could see this (note they all show 0 rules and 0 recordings)

But when I picked and reinstated the backup everything seemed fine and I could see the 27 recordings again

So it looks like I have hit a few bugs here whilst trying to fix the auto start problem.

Thanks in advance for any help


#2

Do you see a DVR icon in the system tray or not?

If you run the DVR installer again you should see an option to change the DVR from system tray to system service.


#3

Yes I do see the DVR in the system tray

System%20Tray

but I don't see an option to change to a service

Installer

Thanks for your help


#4

Hit Stop DVR and the system service option will appear


#5

I hit the Stop DVR Engine button, the web UI on Channels DVR stopped working almost straight away but after 30 mins the installer was still showing (ie the nothing changed)

Installer

At some point above the system tray icon had been removed. After the 30 mins had elapsed I clicked the "Stop DVR Engine" button again and this time I got,

Installer_2

So I clicked the "Install DVR as background service" button. The web interface started working again and the installer changed to

Installer_3

Their still was no system tray icon and if I when to services I could see the following service

Service

To test I rebooted the server and the web UI for DVR was working after the reboot. So other than the few installation oddities and javascript errors above it seems to be working now. Thanks very much for your help.


#6

Great, glad you got it working. When running as a service, no system tray icon appears since the DVR is running in the background and runs even if a user isn't logged in.

I'll take a look at the various errors you ran into. Thanks for documenting them!