Won't delete

Not a big deal but one of my recorded channels will not delete on first try. PBS
I have to do it again and it will delete.
Using pr2100 and ATV

Do you mean hide the channel?

No I mean after watching a PBS program every night I try to delete it and it takes two tries before it is deleted. I can delete other programs with one try just not BBC World News on PBS

That's very odd.

So you go to delete the recording, but it is still visible and available in the Channels app...but when you delete it a second time, it disappears as it should?

And recordings from other channels act differently? That's very odd as there isn't much difference in recordings according to the DVR server.

Are these recordings still in progress?

Let me do some more trouble shooting. I never tried to play it again after the first delete. As I said not a big deal just curious. I will get back to you, Thanks

I have the same issue when deleting a show that I haven't watched. It can, occasionally, happen when deleting a show that I watch and save to rewatch... without watching it a second time. If that makes sense.

Deleting from which app? Or using the web UI?

I almost always use the firetv 4k. I don't recall having it happen when using the shield tv.

I think I found the problem. When I tried to set up a pass with BBC world news I used new only. It would not record at all. So I put all and it worked but it also found the same show on channel 12.2, original was on 12.1. Of course it showed the other one which I didn't delete until the second try.
Now I put it back to NEW only. Will see.

Yes the problem still exist . If I don't put all then nothing records. New doesn't do it.

Do you see NEW badges next to the future airings? They might not have that metadata. In that case, they wouldn't be recorded when you have "NEW" set in your pass.

There is no new badge. It used to work at one time. So what now?

Please click Submit Diagnostics in the app after clicking delete and it doesn't work.