XML EPG Exported from IPTVBoss won't work in Channels

I keep getting the following errors when trying to redownload my XML guide files:

2024/02/11 16:18:38.935288 [ERR] No stations available in lineup XMLTV-Anonymous after guide data download: XML syntax error on line 1: element <input> closed by </form>
2024/02/11 16:18:38.935546 [ERR] Failed to get placeholder channels for lineup XMLTV-Anonymous: XML syntax error on line 1: element <input> closed by </form>

The same files work perfectly fine when imported to Plex, though. The guide populates there, but not in Channels.

This has been happening since early January, I tried rolling back to the previous Channels DVR version and it didn't solve the issue. Nothing else has changed on my end, IPTVBoss is still the same version I've been using for the last year.

The XMLTV spec does not contain any input or form elements. It sounds like your service is giving you malformed XML, and Plex is just ignoring the errors.

Reading the error message, it looks like the URL you are giving Channels is to an intermediary page, asking you to submit something on an HTML form, instead of being a direct URI to a proper XMLTV document.


Hmm, you might be on to something. I have IPTVBoss outputting the files to Google Drive, and I’m using that link in Channels. Maybe it’s getting a Google sign-in page or something even though it’s a direct file share link. I did test the same URLs in an incognito browser to make sure they worked and they still loaded the XML file. Odd that it would start happening for no reason though. I’ll see if I can try something else.

It might be worth a try to:

  • ensure that your GDrive is synced to a local folder
  • when asked for the the URI of your guide data, use file:// with the absolute path to the local copy of your guide data
1 Like

I just want to say thanks for pointing me in the right direction! So I tested the links again in an incognito browser window and got the "Google can't scan this file for viruses, download anyway?" page. This must be the HTML that Channels is seeing.

I looked around for a way to bypass this page, and found another URL structure to use that is now working. If anybody else stumbles upon this issue, here's the URL format I was using which IPTVBoss displays in the "Cloud Links" window:


And here is the URL format that is now working:


So this must've been something that changed on Google's side of things.

On another note, when this started happening I was messing around and thought to myself "I wish there was a way to have Channels use a local file instead of a URL so I can test the XML files directly" and you've just taught me that function does exist, so thanks! I will continue using the Google Drive links for now until I start having issues again, I'm sure it's bound to happen. Then at least I know I can have it use local files instead. Thanks again!

1 Like