Adding YoutubeTV to FreeNAS 11.2 Channels Plugin

I have successfully got Channels server setup and added all HDHomeruns and they stream great from my FreeNAS. But, when I try to add live tv (Dish, YoutubeTV, etc.) to the list of sources I get an error....

exec: "google-chrome":executable file not found in $PATH

Can anyone provide some assistance on why? I have tried in multiple browsers, and have successfully set up the "TV Anywhere" on my "iMac based Channels server" and it all runs fine. So, I know I have the right login...

Any assistance would be greatly appreciated, thanks

You would need to connect to the jail and run

pkg install chromium

You mean through shell when looking at the options for the jail?

This is what happens when I try to install chromium
See upload

Hmm maybe try:

pkg install www/chromium

Still didn’t work...thank you for such quick responses

Maybe @Jmcguire525 has some idea

How did you install the jail? Did you follow my guide or use the plugin?

I don't have any issue with it finding and installing the package, maybe that has to do with it being a manually configured jail.

Try

pkg fetch chromium
pkg install chromium

One difference I notice is the updating dialog after the command, when I issue the command it does not mention the "plugin-repository"

Yea maybe you need to add the FreeBSD repository to the jail first somehow. I'm not a FreeBSD user so I don't know how to do that offhand.

Yeah, I am having the exact same issue with TVE and Spectrum. Been playing with installing FreeNas and setting up Channels DVR plugin.

I am getting the exact same error message.

I have tried updating and upgrading the FreeBDS repository, but it keeps saying it is up to date, but it cannot find a chromium package. Yesterday, I had no issue installing chromium, but I tore that build down and did another today...everything else seems to work, but no joy with TVE login.

Try:

pkg bootstrap -f
pkg update -f
pkg install chromium

Tried that combination with no joy earlier, but all of the sudden I am back to having the issue that I had with my last build...the shell for the channels-dvr jail is not working. The cursor sits at the top blinking, but is non-responsive. Rebooting the entire box does not solve that issue.

It is a good thing I am just tooling around to see if this will work better for me.

You could try a manual install. These are the commands I used when testing TVE, very similar to my old forum post. Read through them if you c/p to make sure the ip address and gateway line up with your install. If it doesn't work just destroy the jail and start again.

echo '{"pkgs":["curl","ca_root_nss","chromium","sudo"]}' > /tmp/pkg.json
iocage create -n "channelstest" -p /tmp/pkg.json -r 11.2-RELEASE ip4_addr="vnet0|192.168.1.75/24" defaultrouter="192.168.1.1" vnet="on" allow_raw_sockets="1" boot="on"
rm /tmp/pkg.json
iocage exec channelstest mkdir /usr/local/etc/rc.d
iocage exec channelstest "pw user add channels -c channels -u 820 -d /nonexistent -s /usr/bin/nologin"
iocage console channelstest
pw groupadd -n admin -g 1000
pw groupmod admin -m channels
cd /usr/local 
mkdir -p channels-dvr 
curl -f -s https://getchannels.com/dvr/setup.sh | env DOWNLOAD_ONLY=1 sh
chown -R channels:channels channels-dvr
sysrc channels_dvr_user=channels
curl -f -s https://getchannels.com/dvr/install-freebsd.sh -o channels-dvr/install.sh
chmod +x channels-dvr/install.sh
sh channels-dvr/install.sh
echo 'channels_dvr_enable="YES"' >> /etc/rc.conf
exit
iocage fstab -a channelstest /mnt/storage/dvrtest /dvr nullfs rw 0 0 
iocage exec channelstest 'sysrc ifconfig_epair0_name="epair0b"'
iocage restart channelstest

Well, I just started from scratch...reinstalled FreeNas...then, the only thing I did before I ran your above commands was set up a pool.

I ran your commands, and they seem to work fine...but, I have ended up back where I was before...when I go to the web ui for Channels DVR, I still get the same google chrome error when trying to set up TVE. My HDHRs work fine. Also, again, after all of that, the shell for the jail does not work. I also cannot use the "iocage console" command from a regular shell or from an ssh session. So, I can't even use any line commands to troubleshoot the jail.

The freenas guys are fixing this for us: https://github.com/ix-plugin-hub/iocage-pkg-build/commit/f225e723240f9e6a9869b8bf901302c96d27509f

I just signed up and currently on my 30-day free trial. I am having the exact same issue. How do I upload this package to my freenas 11.1? Is it advisable to upgrade to 11.2?

So, I am having a weird issue, and I know I have to be doing something wrong because I am a total noob with FreeNAS.
I have no issue installing FreeNAS...I am using an old HP 8100 Elite with an iCore5 (650) with 4 threads and 8GB of RAM. I install FreeNAS on a 120GB SSD and I have a single 500GB hard drive to go with that.
Once installed, I create a Pool (entire 500GB drive) for the jails to live in.
I then install the channels-dvr...I have tried Jmcguire525's method above and also hjd's method from https://community.getchannels.com/t/freenas-11-2-help/10290/11.

Both of these methods work for me and I end up with a Jail, in which channels dvr lives.

This is where my issue starts: I have to create somewhere for the DVR to store recordings, but I cannot create a dataset until the jail is built. But, when I create the dataset, I cannot find any way to change the permissions...unless I set the permissions on the Pool and have it recursively change the permissions on all the datasets below it. If I don't allow writing to that dataset, the Web GUI will not finish the setup...so this is how I get that done. But, every time I change the permissions recursively, I lose the ability to run a shell from the channels-dvr jail.

However, the web GUI still functions fine...until I go to setup ETV...I still get the google-chrome error...even when I know Jmcquire525's method installs chromium...even after tmm1 updated Github to include chromium.

But, since I can no longer use a shell from that jail I cannot do anything (well, except watch stuff from the HDHR sources...which works fine) and have to start from scratch.

Edit: Also, trying to use iocage console command in the main shell to change to the jail's shell does not work, either.

Ok, so the 120GB ssd is your boot drive and the single 500 is for storage? If this is just for testing that is fine but if you are going to need more storage later on yo should get it now, Freenas storage is not easily expandable, plus you may want some redundancy.

First thing to consider is that your storage and jails are separate, before you even start with jails you should go ahead and create datasets for storage. For example, create a dataset called "storage" and in that dataset create another called "dvr".

You can set permissions for each dataset individually, you should read up on permissions and understand them fully, I'm not sure what the default user is when creating the Channels Jail from the plugin, but when you manually create the Jail using my method the User/Group is Channels/Channels and the id is 820.

Honestly, Freenas isn't the easiest OS to jump into, you're going to have to do alot more reading if you want to understand what you're doing and why it is or isn't working. For your use case you may be better off with a linux distro or Unraid.

Here is a look at my datasets, there are also additional datasets under "apps" in which I store the config files for my other jails, that way I can destroy the jails without deleting the config, which makes it easy to reinstall. Channels doesn't need the config stored outside of the jail because it can be reinstalled using the files located in your "dvr" dataset. Again, the "dvr" dataset used for storage will live OUTSIDE of your jail.

Hey, thanks for dropping some knowledge my way...always appreciated. Yeah, this is just a test to get my toes wet. Also, yes, SSD is boot and 500GB drive is storage.

Do you build the dataset outside the Pool or inside the Pool? I have been building inside and unless I create it below the jail, I cannot see it when in the web ui setting the storage for the recordings.

Thanks again for any nudges...I'll play with the setup more, when I get home this evening.

The manual install shouldn't be necessary any more.

The FreeNAS team is adding chromium to the list of available packages, but I'm not sure that their package repo has been updated yet. It might take them a few days to roll it out.