Allowlist Content Limiters Not Working

I cannot get allowlist to work. Testing it on one client. I have the label on a couple of TV shows. I have the server side content allowlist selected the label.

I have tried restarting app/Apple TV. I have tried in regular and TestFlight versions. I am on the latest DVR server beta.

Any ideas?

What are you expecting to see, and what are you seeing instead.

Sorry not enough info....I was expecting allowlist will only show TV shows/Movies with the label selected. I am seeing all TV shows and Movies.

Yes, this what it should do. Please submit diagnostics from the Channels app.

I just submitted diagnostics from the ATV app. Please let me know if you need more info. Thanks.

I see that you have the label Remote added to the allow list of the Great Room client. Is this the client you meant to set it to and are checking?

Yes. And I have this label on a few TV shows but all are showing up.

Probably user error here.

I'm not able to reproduce the issue, as the feature is working for me. It could be that there's another conflicting setting, though it would be surprising.

Have you tried removing all of the other client settings for that client?

I tried removing all client settings but that did not work. So I tried on a different ATV client: lower level. Then I set a new label: family. I added this label to just 1 tv show: justified. And it still shows all TV shows. I sent diagnostics from this 2nd ATV just now.

I am still trying to get this to work. I tried removing the server setting and I got the following javascript error.

I then restarted my server. Added back the allowlist setting (for Great Room ATV, label: family).

It is still not working. All TV shows are listed.

I sent diagnostics.

And here is the kernel panic in my log:

Since I cannot get allowlist to work is there a way to setup a client to only have access to a specific library collection? I see a setting for channel collections but not library collections.


@Maddox Jon - I am still having this issue. Most recent try I added Hide list and that worked. When I use the same label (mike) and then change it to allowlist it continues to show all shows. When I use hide list it does hide the show that I have added the label to (GOT). I did submit the server diagnostics just now. This is for client Great Room.

It would be great if you can look at this again. Thanks.

Hello - bringing this back up. I cannot get Allowlist to work. Hidelist works. I use the same label and a show will hide. When I remove the label from hidelist and add it to allowlist the show shows up but all other shows still remaining showing. There seems to be a bug in Allowlist that does not filter out shows.

I am trying to setup a client that just shows selected library shows and movies. I turn off navigation labels for everything but TV and Movies.

Is there another way to do this? Or can we fix the bug in allowlist setting?

@Maddox Jon can you look at this again?


Hello developers - I realize this is low priority but can someone look into this? Thanks.

Any chance the developers can look at this?

1 Like

I really like Channels and I know there are only 3 developers but at least some type of acknowledgment and follow-up will be appreciated.

It's on our radar.

Please try the latest TestFlight build

It is not working. I am in tvOS TestFlight 6.23.2022. Blocklist works but allowlist shows all not just tagged. Thanks for looking at it.