Anyone Using HLSTube?

Thanks for the response and the heads up about my typo. I will look into your suggestions.

Yes I have experienced this (and believe I even posted about it here awhile back when I was first learning how to use hlstube.) I’ve just gotten into the habit of trying these channels twice knowing it’ll only properly “tune in” on the second try. I’d love if there was an easier, more elegant solution. I’ll check the suggestions above but they seem a lot more complicated. I was hoping Channels DVR could be updated to give more time to tune into the hlstube streams before erroring out.

I’ve been trying to reproduce this issue for the last hour or so and can’t do it. I’m on the the latest prerelease and bata iOS app. Maybe the ever seeing devs have smiled on us.

Hey @psperry, hlstube dev here! If you run into this again, would you mind sharing the logs from your hlstube container in a new issue over on GitHub? I've seen this a few times myself but am having trouble reproducing right now, but I'm sure we can get this figured out. Sign in to GitHub · GitHub Thanks!


I certainly will. It seems to a lot more rare than it used to be. It used to be nearly every time. Wondering if the Channels devs did something to mitigate. It did happen once this morning but my logs only seem to go hack an hour. I will open a ticket when it happens again.

Caught it and saved the logs. Will submit a ticket in the morning.

EDIT: Posted

I need some instructions on how to install hlstube on Docker on Synology NAS. Can you help?

I believe I just secure shelled (ssh) to my Synology NAS, then executed this line as copied from

docker run --rm -i -p 8080:8080

If you already have something using port 8080, then you would want to change it to something else.

1 Like

I did what @cyoungers did, only a bit different.
I use the :main image as it's newer than the :latest image Package hlstube · GitHub

I run the container detached instead of interactive and don't want it removed when stopped docker run | Docker Documentation
so I use

docker run --detach --restart=unless-stopped --name=hlstube --env TZ=America/Los_Angeles -p 8080:8080/tcp

Anyone using HLSTube get interrupted recordings with this error?
Transcoder Reset: Playlist skipped to a higher sequence

Recording one hour segments of a live feed on avg. 15 times per week I get them randomly, maybe one out of 20+ recordings. The interruptions so far have caused a loss of anywhere from 20 seconds to a couple minutes of program material in the recording.

Reported it when first encountered and here's what I was told

I.m pretty sure HLSTube only caches the master.m3u8 for five hours.
Maybe @jnewland has seen this or has some idea of what's causnig it.

HLSTube continues to work very well for me with a large number of webcams and live streams.

I can't get this LAX Live stream working though, and I think it's because there are two camera feeds to switch between? I'm only interested in camera #1 though. Can HLSTube work with this kind of YouTube link?

CleanShot 2022-11-12 at 08.50.29

I was never able to get HLSTube to work on the LAX live stream YT feed. Also figured it must be the two feeds that foul things but for HSLTube. So I had to use youtube-dl to create the m3u8 lines required in the m3u for a source.

youtube-dl -g

I built a Keyboard Maestro macro that runs every 4 hours to regenerate the output from the youtube-dl -g command. I setup a separate source defined in Channels DVR pointing to this updated m3u file just for this feed.


I spoke too soon, perhaps I jinxed something? :frowning: I got warnings about my iMac server's hard drive dying so I cloned everything to a new bootable drive. Everything is working fine... except for hlstube, which is no longer working. I have it installed and running using Docker Desktop. But now when I try to watch the same streams that used to work fine, I'm only getting "could not fetch playlist: 500 internal server error" in Channels DVR.

Here is the log output from hsltube:

I was just trying stream from


Or this Santa Monica WebCam:


These previously worked fine. I feel like I'm missing something obvious but don't know what to try to troubleshoot. Any tips, tricks or help appreciated!

EDIT TO ADD, 3/23: I did a reinstall on a new Mac and got Docker Desktop and hlstube working again.

1 Like

Not sure if @jnewland is still updating hlstube
It quit working for me today due to an outdated version of yt-dlp in the container and just shows retyring... in the log,
Running the version of yt-dlp interactively in the container errors out with
"Unable to extract uploader id"

$ yt-dlp -U                                                                                       
Latest version: 2023.02.17, Current version: 2022.02.04                                                             
ERROR: It looks like you installed yt-dlp with a package manager, pip or; Use that to update               

$ yt-dlp -g ''                                         
WARNING: [youtube] Ignoring subtitle tracks found in the HLS manifest; if any subtitle tracks are missing, please re
port this issue on , filling out the "Broken site" issue template properly. Confir
m you are on the latest version using -U                                                                            
ERROR: [youtube] 9Auq9mYxFEE: Unable to extract uploader id; please report this issue on
yt-dlp , filling out the "Broken site" issue template properly. Confirm you are on the latest version using -U; plea
se report this issue on , filling out the "Broken site" issue template properly. C
onfirm you are on the latest version using -U                                                                       

The latest version of yt-dlp works, but how to get that in the hlstube container?

I download the latest standalone linux version from GitHub - yt-dlp/yt-dlp: A youtube-dl fork with additional features and fixes
Did a chmod 755 on it and copied it over the old one in the container using docker cp.
docker cp yt-dlp_linux hlstube:/usr/local/bin/yt-dlp
It works now (until I replace the container).

$ yt-dlp -U                                                                                       
Latest version: 2023.02.17, Current version: 2023.02.17                                                             
yt-dlp is up to date (2023.02.17)                                                                                   

Mine is jacked up as well. I tried going to the docker page and its gone. Could you upload yours with the fix maybe? That would be awesome :slight_smile:

Not sure what you mean. I can see them Package hlstube · GitHub
Unless you mean your container was deleted?
That will happen if you use the default run command using the --rm option.
Here's the run command I use instead.

docker run --detach --restart=unless-stopped --name=hlstube --env TZ=America/Los_Angeles -p 8080:8080/tcp

There's nothing to upload. I just replaced the executable in the container with the new one I downloaded.
See docker cp | Docker Documentation

Updated to use tag :latest instead of :main in the example docker run command

1 Like

Hey folks! :slight_smile: I just released with the latest version of yt-dlp. Please let me know if you run into any trouble with it!


Thank You!
Back to working great, as usual :smile:

Trying to determine why hlstube quit streaming and returned a 500 Internal Server Error.

Is it a problem with hlstube, or something wrong with youtube.

After streaming the site for about 58 minutes, Channels DVR log says Could not fetch playlist get returned 500 Internal Server Error

Nothing in the hlstube docker container log, other than it stopped reporting
streaming to <IP>:<PORT> about 36 seconds before Channels DVR logged the 500 error.

This happened once last night and it's been working fine since then.
It has happened a few times in the previous months, so I setup a task a few weeks ago to restart the container every morning.

Any ideas?

Noticed something else in the hlstube container log from three days ago, but it didn't seem to affect that stream.

asking <IP>:<PORT> to retry

Don't know what that means or if it's related to the 500 error I got yesterday, but it's the same site.

Still haven't found the root cause, but according to my router wan dhcp client log, my router lost its network link to my gateway. So the Internet connection dropped for about 3 minutes, resulting in the 500 error. hlstube lost its Internet access.

Trying to troubleshoot why Channels DVR thinks the hlstube stream is not available.
Usually have no issues, but once in awhile this happens.

Channels DVR log shows 138 retry attempts by Channels DVR to stream failing with the same error for 6 minutes, 55 seconds after it started.

2023/03/03 18:59:00.004821 [DVR] Starting job 1677898740-614 TheChannel @ 7PM on ch=[3777]
2023/03/03 18:59:01.070056 [ERR] Failed to start stream on channel 3777 via M3U-TheChannel: M3U: Stream Not Available
... 137 identical failures
2023/03/03 19:05:55.834968 [ERR] Failed to start stream on channel 3777 via M3U-TheChannel: M3U: Stream Not Available

The job never recorded anything.

All that time the hlstube docker log shows it streaming to Channels DVR, with the port# for Channels DVR changing after every 2 lines.
I'm assuming this is because each time Channels DVR retried streaming it used a new port.

2023-03-04T02:59:01.023988788Z	stderr	2023/03/03 18:59:01 streaming to
2023-03-04T02:59:01.066539680Z	stderr	2023/03/03 18:59:01 streaming to
2023-03-04T02:59:02.161636361Z	stderr	2023/03/03 18:59:02 streaming to
2023-03-04T02:59:02.205658224Z	stderr	2023/03/03 18:59:02 streaming to
... identical log lines with just time and port# changing
2023-03-04T03:05:49.934834778Z	stderr	2023/03/03 19:05:49 streaming to
2023-03-04T03:05:49.977813530Z	stderr	2023/03/03 19:05:49 streaming to
2023-03-04T03:05:55.789466487Z	stderr	2023/03/03 19:05:55 streaming to
2023-03-04T03:05:55.831966647Z	stderr	2023/03/03 19:05:55 streaming to

Also, not sure what this means in the hlstube docker log that occurred on the same channel about 4 hours before the above failure.

2023-03-03T23:10:44.274828903Z 2023/03/03 15:10:44 reconfiguring
2023-03-03T23:10:44.275336394Z 2023/03/03 15:10:44 asking to retry
2023-03-03T23:10:49.873433970Z 2023/03/03 15:10:49 reconfiguring
2023-03-03T23:10:49.873613029Z 2023/03/03 15:10:49 asking to retry
2023-03-03T23:10:54.860558613Z 2023/03/03 15:10:54 retrying
2023-03-03T23:11:00.036327696Z 2023/03/03 15:11:00 reconfiguring
2023-03-03T23:11:00.036517351Z 2023/03/03 15:11:00 asking to retry
2023-03-03T23:11:02.688309819Z 2023/03/03 15:11:02 reconfiguring
2023-03-03T23:11:02.688488470Z 2023/03/03 15:11:02 asking to retry

Might just be time to give up on hlstube and use the Kister method instead.

UPDATED: This may be due to my router settings.

Time will tell.
The forum won't let me add a new post, so adding it here. Looks like hlstube is dead.