ATV4k guide data Lazy

@mnwxman132 Can you try this latest build to see if it's any better?

1 Like

Hi @eric

I installed latest TestFlight build over night. It seemed fast and snappy at first so i was excited. The issue seems to get worse after a long inactivity - like over night.

This morning the symptoms reoccurred as soon as i opened channels. On the apple tv i had missing guide data from about an hour into the future. On the ipad i took a screenshot of the “lazy guide” symptom.

submitted diags from both the ipad and apple tv, quickly just as i was seeing the issue

1 Like

Okay. I’ll try that tactic to reproduce the issue.

1 Like

Can you see if this one works any better?


Hi eric,

Edit. I just notice two beta updates ahead of the one i was on. One came in this morning. Ill retest everything. Im leaving the rest of this post in case any of my observations help. ….


I observed the same symptom this morning on my ipad. At least this morning however it wasnbetter on the apple tv, but there are two use cases - see below

On the ipadI i took a screenshot as it was happening.
Unfortunately i couldn’t submit beta feedback from the app. It is stuck and wont go to the next menu to submit anything. Is the submit feedback menu in the testflight snubbed out in the code?
However was able to sent diagnostics from the app but this was many minutes after the guide eventually loaded.

I can wait again after a long pause and submit the screenshot from the share sheet next time the guide is stuck with less delay hopefully while its in the stuck state. Now with beta update from 1/14

Also, on my apple tv, i have a different use case and i did not observe the lazy guide this morning. On my apple tv i automatically load a live station on start up. It seems that loading the station and then going to the guide helped the guide load normally this morning. So possibly there is some improvement from earlier in the week

On the ipad i set the start up settings to statically go to the guide.

Also, please note that whenever i manually shut down the app in the app switcher (both clients) , or for some reason channels forces a restart the - like after software update, whenever i see the “preparing guide message” the guide always loads just fine.

Hope this helps, and let me know if there is anything else you want me to try to duplicate the issue. .

1 Like

Hi Eric,

Still happening on ipad with latest prerelease.
Submitted screenshot and diagnostics from the ipad while the guide was stalled.

Ill check the apple TV tomorrow in the morning after long overnight pause.

Thanks! These logs are helpful. I'm looking into it further.

Can you see if this build solves the issue? I appreciate all of your testing here.

1 Like

Will do.


Ipad channels looked great this morning after overnight delay.
Guide came right up populated as expected

This version looks promising! Apple Tv also ok

Hi @eric

I submitted diagnostics from the ipad app and sent a snapshot while this symptom was going on. Slightly different symptom. Some channels future programs are all black. This was after a 3 hour inactivity window. Ill check later if the other symptom arises.

Note: eventually by popping out of channels to write this post, and then checking again, the black guide data did refresh. Maybe out 2-3 minutes.


I've made some additional improvements to the guide data. Hoping this one is the one that solves it for good.

Looking very promising. I havent seen the lazy guide or the sluggish guide at home at all since updating.

I did observe some laziness remotely when i was coming in through tailscale, where it took a bit of time to sync the guide data.

Otherwise, at home its looking great!

Edit: 2 days in seems much more stable. Thanks @eric

That's great news! I haven't been able to reproduce issues on my setup either.

That's great news! I haven't been able to reproduce issues on my setup either.

I’m going to mark this as solved. @eric thanks for all your work on this.

@eric @Rice before marking this as solved fully.
I did notice lazy issues when coming in through tailscale today on my iphone. It was not on the 1/17 release. I updated to todays 1/19 release and have not been out and about to test that version yet.

Nevertheless, when im at home its looking great.

Should we start a different thread for lazy guide lag on tailscale and mark this as solved, or continue investigating.

Im happy to try and capture that scenario when im out and about next.
Please let me know what helps eric. The tailscale lag was still very usable, but has the same symptom of having to switch sections to refresh the guide.

And of course thank you as always for the stellar support!

1 Like

I believe this latest build will have improved the situation on slower connections like Tailscale as well. You can keep this thread open to talk about that if you’re still having problems with that.

1 Like

Hi Eric,

Ive notice the lazy guide issue creeping back in the past several days.
I submitted diagnostics from the apple TV app.

Heres a screenshot, as it was happening…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.