ATV4k guide data Lazy

Guide data disappears until you select a different channel list. ATV4k, stable non beta app release, does this daily. Any ideas? Launched app, guide is blank simply move from current list to another loads the guide data for other list.
Server hardwired atv hardwired. iPad does not have this issue. Once data comes back up it’s good for awhile.

Diagnostics submitted from atv app

Yes, I have been noticing the same thing recently, on all three of my AppleTVs, on the latest TestFlights and Server beta.

Yea I've seen this too recently. We will take a look.


Can you try this latest Testflight build and see if it's any better?

I'm testing now, seems to be good so far. I'll need a day or two to know for sure. Will report back!

1 Like

Well, I’ve tested for a bit now and haven’t experienced the “lazy guide data” bug after updating to this latest TestFlight, so I think it’s been fixed. Thanks!


Im still seeing it on apple tv and ipad.
Latest dvr beta and testflight build

1 Like

@mnwxman132 I’m not sure that is the same bug based on your screen shot. We are talking all data is missing then a complete guide will show up after changing list. Your data is there but not much of it.

@eric So far the beta is seems to have fixed it. I’ll keep an eye on it for a couple more days before marking it solved.

@mnwxman132 can you submit diagnostics from the app when you see something like this?

I have been seeing both completely unpopulated guide “sluggish” as well as incomplete downloads.

In both cases going to a different tab filter replenishes the guide data. Or of course, closing the app with the app switcher.

I will submit diads next time i see either @eric

@eric I just submitted diags from my ipad which is on latest testflight beta.
Guide does not load any program info until a filter change, or a very long delay. In this case it was about a minute before program info filled in

1 Like

@mnwxman132 How soon after that screenshot did you submit diagnostics?

That as within 30 seconds or so.

I submitted another diagnostic about an hour later with my ipad with same issue and included a screenshot with the diagnostic. That was within a few seconds of opening the app and sending everything

Thanks for these submissions. I think I've gotten a couple paths to investigate here.

1 Like

@mnwxman132 Can you try this latest build to see if it's any better?

1 Like

Hi @eric

I installed latest TestFlight build over night. It seemed fast and snappy at first so i was excited. The issue seems to get worse after a long inactivity - like over night.

This morning the symptoms reoccurred as soon as i opened channels. On the apple tv i had missing guide data from about an hour into the future. On the ipad i took a screenshot of the “lazy guide” symptom.

submitted diags from both the ipad and apple tv, quickly just as i was seeing the issue

1 Like

Okay. I’ll try that tactic to reproduce the issue.

1 Like

Can you see if this one works any better?


Hi eric,

Edit. I just notice two beta updates ahead of the one i was on. One came in this morning. Ill retest everything. Im leaving the rest of this post in case any of my observations help. ….


I observed the same symptom this morning on my ipad. At least this morning however it wasnbetter on the apple tv, but there are two use cases - see below

On the ipadI i took a screenshot as it was happening.
Unfortunately i couldn’t submit beta feedback from the app. It is stuck and wont go to the next menu to submit anything. Is the submit feedback menu in the testflight snubbed out in the code?
However was able to sent diagnostics from the app but this was many minutes after the guide eventually loaded.

I can wait again after a long pause and submit the screenshot from the share sheet next time the guide is stuck with less delay hopefully while its in the stuck state. Now with beta update from 1/14

Also, on my apple tv, i have a different use case and i did not observe the lazy guide this morning. On my apple tv i automatically load a live station on start up. It seems that loading the station and then going to the guide helped the guide load normally this morning. So possibly there is some improvement from earlier in the week

On the ipad i set the start up settings to statically go to the guide.

Also, please note that whenever i manually shut down the app in the app switcher (both clients) , or for some reason channels forces a restart the - like after software update, whenever i see the “preparing guide message” the guide always loads just fine.

Hope this helps, and let me know if there is anything else you want me to try to duplicate the issue. .

1 Like