Audio lags video, air play 2 speakers (HomePods)


#42

After some more testing I am finding that I still have the audio sync problem. My work around is to restart the AppleTV and then Channels and audio sync is fine.

I will try the following tonight:

  1. Restart AppleTV choose home pods for audio and start netflix or hulu.
  2. Close Netflix or hulu and try starting channels to see if audio still in sync.
  3. Close channels and choose different app like Hulu or netflix to see if audio in sync.
  4. Restart AppleTV choose home pods for Audio and start Channels.
  5. Sleep AppleTV for a few hours and see if Homepods are still connected and start Channels and check audio sync.
  6. Close Channels and choose hulu or netflix to see if audio still in sync.

#43

Here are my test results:

  1. Restart AppleTV choose home pods for audio and start netflix or hulu. - Passed
  2. Close Netflix or hulu and try starting channels to see if audio still in sync. - Passed
  3. Close channels and choose different app like Hulu or netflix to see if audio in sync. - Passed
  4. Sleep AppleTV start Channels. - Failed - Audio out of sync.
  5. Choose Netflix or Hulu - Passed.
  6. Unselect Homepods from Home screen by holding play/pause button. Select Homepods.
  7. Open Channels and Play Live TV - Passed.

Conclusion - It appears that Channels has a problem when the AppleTV comes out of sleep mode to active the HomePods for Audio. Other apps like Hulu or Netflix don’t exhibit this behavior.

Two workarounds - Restart AppleTV or Unselect and Reselect the HomePods after AppleTV comes out of sleep mode.


#44

Tested the new “Channels ATV Beta 2018 (7.21.246)" today

Both Homepod and Apple TV sound in sync :slight_smile: :slight_smile:

To adjust volume on Homepod only works via voice command to Siri Homepod e.g. “hey Siri, volume to 50%”

Apple TV volume adjusted via Apple TV or Tv remote control.


#45

What version of tvOS are you using? We haven’t changed anything on our side…


#46

TvOS 11.4.1


#47

Looks like this build, 2018.09.03.1701, has fixed this problem for me.


#48

Just checking back in here. Many ATV4 apps have added an “audio” menu item at the top of the application to allow Airplay2 audio destination selection. I use it to select my stereo HomePods. Is Channels planning to add this function. I can still select the ATV4 audio destination on my iPhone, but it would be more convenient if the menu was within the Channels app. Otherwise the HomePods work fine with Channels if you pause the stream to sync the audio.


#49

For months, I had the audio lag issue with the Apple TV 4 and a single HomePod. However, it did go away and all was well for a long time. I suspect one of the Channels Beta versions fixed it. I have been using all the Beta versions of both Apple TV and Channels TV app.
Recently, I updated HomePod from 11.4 to 12 and the audio lag issue returned. Just curious if it’s me or if others have seen this as well using HomePod 12? I am also on TVOS 12.


#50

I started using 2x HomePod Speakers in Stereo with tvOS 12 and HomePod 12. I have never seen an issue with voice sync. My only problem is the thread I started related to they stop working after SLEEP. When trying to figure out my problem I did turn off the Channels Setting to use Stereo which did not help my problem. Now I wonder if should be turned back on?