Automatic Commercial Skip Not Working

Anyone else having issues with Automatic commercial skipping not working? If set to "Skip Button" it works fine.

I have a FireTV Cube Gen2 running Channels DVR Client 4.6.1. Channels DVR Server is 2023.01.23.1746. Automatic skip works fine using my iOS client.

ya, its not working for detected commercials recorded from playon.

Playon is supposed to put the commercial markers in the recording file.

channels is showing the recordings with commercials detected. it just doesnt auto skip them.

Any change with Settings > Playback > Advanced > Video Decoder: Software?

What version of Channels app on your fireTV? Maybe try the beta version?

No change when switching from hardware to software decoder. Channels app version 4.6.1. Also tried beta 2.1.435.

I tried running a re-detect commercials and it ran and found commercials fine but upon playback a setting of automatic still does nothing to skip them...just keeps playing thru commercial.

They are working fine on my FireTV latest Cube and my Fire TV. Go to Manage Apps Stop Channels DVR ... clean all data and restart the APP.

Force stopped, Cleared Data, cleared cache.....restarted, no change still does not auto skip commercial.

I will test on a FireTV 4K Stick later and report back. One difference I see is it sounds like you have Gen3 cube whereas I have Gen2.

I also have an Amazon Fire Televison and that works.

Thanks for info. I just tested on the FireTV 4K Stick and saw the same non-skipping as my Gen2. My recording originally came from PlayOn. I just tested auto-skip on an old recording that did not come from PlayOn and it worked fine.

It appears that this has something to do with PlayOn..... I am just surprised that taking a PlayOn recording and re-detecting commercials in Channels does not seem to fix.

I just tried a new Peacock show via PlayOn and tested. Automatic Skip works on it. Perhaps it was a temporary problem. @TexasYeti Have you tried any new PlayOn recordings to see if auto-skip works?

It gets even stranger....sometimes it works, other times it doesn't! In a one hour show I had 5 commercials, auto-skip worked on 1st, 4th, and 5th. After 4th works, I rewind to before the 4th commercial and it fails to auto-skip. Same with 5th. I try rewinding a few times and am never able to get it to auto-skip a 2nd time for a commercial break. Very strange. Any ideas?

This part is how it is intended to work. If you rewind because the marker was wrong you need to be able to watch without it fighting you and jumping ahead over and over.