BETA: Audio improvements for Apple TV and iPhone/iPad

I can't locate the folder. I'm using a QNAP NAS if anyone can provide some guidance.

We can only help with so much, it’s your device and no one else has access to it. But you can see the path to the directory you chose to save recordings to on the main Settings page of your Channels DVR Server web admin.

I uploaded the file. Thank you.

Thanks. The issue should be fixed in the latest beta. Please try it and let me know.

1 Like

For the last few TestFlight builds with experimental video and audio, I've been seeing a lot of "catch up" when skipping backwards or forwards. The video will play for 3 seconds without audio, then audio starts playing while the video is frozen, then finally the video restarts and everything is in sync.

Is this expected performance for now? I feel like builds from 2-3 weeks ago only took about one second to sync up, but I know others had issues with those builds like distorted audio.

1 Like

What kind of speakers?

HomePod mini stereo pair. I can submit diagnostics next time I use Channels.

1 Like

@tmm1 Just submitted diagnostics.

1 Like

I started having the random pausing again on ESPN this morning. I submitted Diagnostics from my Apple TV running Channels BETA 11.26.2014. However, this might need to split into a separate topic as I moved back to the Default Audio driver to troubleshoot some other issues so this pausing issue has happened both with default and experimental audio driver. The ESPN feed is via HDHomerun Prime. Thanks.

1 Like

Is it happening during commercial breaks?

Can you find a recording that does the same thing?

Thanks for the reply. Only between commercials and sometimes from a commercial back to the show. I've only seen it happen on ESPN and ESPN2. Once this recording finishes I'll see if it replicates. I tried that before and it appeared to only happen when playing live and didn't flow through to the recording.

1 Like

I was able to review the recording this morning and did find it happening on there as well. If you want a copy of the recording, please let me know how you'd like it sent. I can give you some time stamps where it is occurring. Thanks.

Thanks for checking. Please upload it here:

Let me know what timestamps the issue occurs at.

Also please try the next TestFlight build (v2021.11.28.1717). I believe it should fix the problem in the default driver. If it still happens with the experimental driver, please submit diagnostics after it does.

Thanks - I updated to v2021.11.28.1717. The pausing definitely seems much improved on the default audio driver with some stuttering on the experimental. Below are the details:

College Gameday 11/27/2021 - Viewed on Apple TV Beta
Filename: College GameDay 2021-11-27-0759.mpg

33 min - After Monday Night Football Commercial
34 min - After Houston Methodist Commercial
51 min - After ‘Hawkeye’ Commercial
52 min - After Comcast Commercial
94 min - After Taco Bell Commercial
95 min - After Commercial
107 min - After Monday Night Football Commercial
108 min - After QClothier Commercial
119 min - After Hulu Commercial
120 min - After Commercial
136 min - After CMA Christmas Commercial
137 min - After CNBC Pro Commercial

Could you confirm that you received the file? I've been getting a "less than one minute" left message on the upload for a while, but it shows a green check next to the filename. Thanks again for all of your help.

1 Like

I got it, thanks.

Is default back to normal now, or still funky?

Can you submit diagnostics after experimental stutter


Diagnostics submitted with Experimental stutters.

It's hard to say on the Default. It seems to pause for a second (minimally), but then continues (unlike before where it just stopped playing). I'm wondering if that's just part of the broadcast that is throwing things off. I've only seen this on ESPN and ESPN2.

I meant compared to stable store build I guess

I tried to watch Hallmark channel (no judgement please) on the new beta with the default audio driver and it kept pausing many times. The timeline bar would come up and then it would play again. Had to go back to stable version. Will try some other sources a bit later and see if the beta shows issues there too.

Trying to watch ATSC 1 from HDHR. Audio is popping and has an underlying garble, not clear. Also pausing and bringing up timeline.

I would still describe the sound as when you play a bad audio CD.

Logs sent

Am i missing something? i'm using airpod pros with the experimental driver and before i turn on spatial it says multichannel ready for a surround sound movie - but when i turn it on it says spatial stereo

What am i missing?