Buffering excessive on AppleTV and IPad When remote

I have an nvidia shield running channels DVR server and everything works great in network. When remote to the server the buffering is excessive. It’s unwatchable. Have changed from Original all the way to 2MBPS and doesn’t get any better. Tried it on IPad and AppleTV and both suffere severe buffering. It does it for TVE and HDHR channels. Internet speed at the remote location is well over 200Mbps download with upload of 35M or so. On IPad cellular same thing, lots of buffering. Any ideas?

1 Like

The remote upload is meaningless. What is your upload at the site hosting the dvr? Also is the server wired or wireless?

Server is wireless with speed of 250 upload.

What are the results of a Channels DVR speedtest from the iPad when remote?
For remote test use http://my.channelsdvr.net/speedtest or [abc].channelsdvr.net:8089/speedtest

Please go to Settings -> Support -> Submit Diagnostic Logs from your device and let us know when it's been submitted so we can have a better idea of what was going on.

I just submitted them while operating iPad on cellular. Closest to the remote internet in result even though the remote internet was actually faster.

I see you're having some small issues with reception. Do you have any problems watching from home?

There are certainly some strange things I see in your logs. I do see some timeouts and low download speeds that would point to network problems, but I also am seeing some long (2-5 second) encode times for a segment, which is not normal.

The download speeds that I'm seeing do not in any way match the speedtest you posted. That speedtest was run from outside the house?

Yes, what’s strange is that the speeds seems to vary wildly but only with channels running. In the house it works pretty much flawlessly. I will see some issues with recordings missing a second or two but this is the first time I have tried outside the home network. Both AppleTV and IPad had issues playing TVE and HDHR. This is another Speedtest I did just after the other one.

Do you think it could be the Shield? Or the apple products?

I just sent another set of logs from when in the home network.

It seems more likely the Shield vs the clients, but I'm still not sure what would be causing the issue. Are you running a lot of services on the Shield?

1 Like

I would try to eliminate WiFi, at least temporarily as a test.
If you can use wired network between your sources, your DVR and the Internet.

Really the only thing running is the android system and Channels Server.

I’ll try that tomorrow, thanks.

I moved the shield to ethernet and I deleted the server app and reloaded it and set it up again at a different IP address. Seems to be working much better now. I do have one question. If I have a USB drive on the shield with recordings on it why can’t the new server see them? It shows the dvr 50% full but no recordings show up under the library.

If you reinstalled you would need to restore backup for the previous recordings to appear

Perfect thanks!

I have Channels DVR Server running on an Nvidia Shield Pro and it is basically the only thing the Shield is doing. When on Cellular (logs just sent a few minutes ago 3/16/23 at 11:28 or so) or remote on WIFI outside the home the buffering is horrendous. I have the Shield connected via ethernet (Fios 1GB service) and am getting over 300Mbps on 5G on my iPad and the buffering is still bad. On wifi outside the home it is just as bad. I uninstalled and reinstalled Channels DVR Server with no relief. I am not sure what to try next. It buffers on TVE or HDHR content. I thought it had gotten better but no, still sucks.

Looking at the last few playbacks in your diagnostics, you were running into timeouts that indicate intermittent networking issues between your client and the server. These things happen on the internet and there isn't much we can do to diagnose what hop they happened on. When your connection is working, it is fast, but you do seem to get these timeouts from time to time.

I am on fios GB but I also noticed that my speeds are not symmetrical. I get great download speeds but uploads are at times less than 100Mbps. Could this have something to do with this issue? I am starting to think maybe I have a bad router or ONT.