BUG: Android 3.5.2 Stream Links No Longer Work

Very suddenly (like I mean a half hour later with nothing else changing), Stream Links no longer work on Android/Google TV. At first, it was just my CCWGTV on 3.5.2 and it was working on my TS4K+ on 3.5.1, but I updated the app and the OS (looks like it was stuck in the past due to space issues) and now it is having the same problem. Instead of opening an app (or attempting to open one it cannot), it is trying to play the file with Playback Failed (-17).

Also, just to be sure, I updated to pre-release 2021.07.23.1501, rebooted everything, all that jazz. It made no difference. I then attempted on my Android Phone and got the same issue. There does not seem to be a problem in the web, so it looks like something is not talking from the Google side.

CCWGTV Diagnostic: 8263e423-a762-44f8-885a-4a8ebb9b1c93
TSK4K+ Diagnostic: 5bfb61c9-712a-4fdc-a3d3-c201b4691dcc
Android Phone Diagnostic (Off Network): f1153e9a-4a19-4c9f-a132-f36dd39d1f03

EDIT: It seems to be specific to TV Shows and Movies that it groups as an "episode". Other movies appear to be launching. I have tested the same with Netflix, Hulu, Disney+, Kanopy, and Hoopla.

@babsonnexus I'm new to Channels and Stream Links. I did try Stream Links for Amazon Prime but could not get it to work. I see you listing Kanopy and Hoopla which I didn't see listed on the Channels page describing it. Is there a comprehensive list of all possible compatible apps?

@tmm1, @maddox, @eric:

I can 100% confirm this bug is created in Android APK 3.5.2. I have manually downgraded/installed 3.5.1 on CCWGTV, TS4K+, and an Android Phone (off network) and all work as expected.

The bug is officially this:

  • On Android TV, all TV Shows and Movies that it thinks are episodes attempt to play a file through the default player as an MPG instead of launching the link. Movies that are listed as Movies launch with no issue.
  • On Android for Phones/Tablets, Movies of all type also fail in the same way.

And just to be clear, I eliminated all other factors including using a separate install of the server on another machine/network on stable release and removing any other intermediaries on network (i.e., PiHole). The only thing that made any difference was the Version of the APK.

@Dinki, I think your issue may also be the version of the app. 3.5.2 seems to have a pretty massive bug making Stream Links useless. You'll have to manually downgrade to 3.5.1. If you are unfamiliar with how to do this, my recommendation is this:

(1) Uninstall the Channels DVR App
(2) Go to https://m.apkpure.com/channels-whole-home-dvr/com.getchannels.dvr.app, scroll down, and download version 3.5.1 of the app
(3) Get ADBLink for your computer (http://jocala.com/) and follow the directions on there to connect to your streaming device
(4) Using ADBLink, click "Install APK" and select the file you downloaded earlier.
(5) Make any setting changes you did before in Channels.

As for a comprehensive list, the answer is it will work with any app so long as the app has the correct code. For instance, Disney+ understands that a link when clicked should open the app, and it does. Hoopla understands this as well, but the App is coded wrong so that it opens the mobile version instead of the TV version. Kanopy is not coded at all, so you get this error:

The problem is, there are literally hundreds of apps that stream media so the Devs can't test them all. Conceptually, Stream Links takes advantage of base coding, but it is up to the developers of those apps to code correctly to make it work.

I can only confirm that Netflix, Disney+, and Hulu all work as expected, excepted Hulu has a problem when once it is open on Android TV it will not work until it closes in the background. As for anything else (beyond my notes about Hoopla and Kanopy above), I cannot say.

1 Like

Thanks for the information on this. I'm familiar with side loading so this shouldn't be too difficult for me. I probably won't have time to do this soon unfortunately.

@babsonnexus So I found a minute and installed 3.5.1 . I could not get it to play the link on my FireTV. I received the "Can't play this link" or something similar. This is different than the Playback error -17 I was getting but still no good.

I responded in the Amazon thread, but just to sum it up here:

  • Amazon's app appears to have broken Deep Linking. It is not exactly similar to Kanopy because it does not give the same error (or any error), so there may be something in the code of the Channels app that is intercepting Amazon links.

  • Android APK 3.5.2 has broken almost all of Stream Links functionality requiring a downgrade to 3.5.1. Separate issue entirely. The same issue is prevalent in the latest Beta, too.

1 Like

@tmm1, can we get a Version 3.5.3 of the Android APK that only has this fix? Getting really tired of having to keep downgrading to 3.5.1 or stopping automatic updates.