BUG: FireTV4k not switching refresh rate

When i play back 1080i 50hz content Recorded by the dvr here in the UK in original mode (i.e not transcoded) my tv does not switch resolution / refresh rate and tells me it is playing content in 1080p 60 instead of 1080i 50

Channels settings:

Frame rate matching - when playing video
Decoder: hardware
Strech to fit:on

FireTV: automatic (for all display options)

The net effect is that while 1080i hd content no longer crashes the fire tv, it has so many artefacts and interlacing issues with fast moving content (jagged lines and stripes etc) its is basically unwatchable now..

Whats worse is that if i drop back from original to transcoded 720p instead (which used to work and look great) it now does nothing and just black screens then says playback failed

And worse even than that.. i now no longer have the option to use the old transcoder which also worked...

So i now have a totally broken experience and no options to fix

Please help / sort the firetv app and transcoder for UK hd 1080i content asap

What version of the dvr and what version of the app?

Lastest beta build of dvr (i.e today) and app version 2.1.14


Could you turn on this option to use the old transcoder and try it?

Rebooting the firetv, switching back to the old transcoder and setting the content to transcoded at 720p 6mbps has it got it working again...

I am also on a synology nas with 8gb ram

I guess i just stick back on transcoded for now on firetv until there is a fix...

Can you try the new transcoder one more time? I’m very surprised it could make a difference in this case. The underlying encoder is the same for both.

Sure i will untick use old, reboot, leave it at 720p 6mb and will try it again

I also not that rate switching is not working.. 720p transcoded source and tv thinks 1080p 60

Weird.. seems to be working on the new transcoder after the reboot:

757.98 GB available


Watching recording Hairy Bikers Route 66 S01E04 2019-10-10-1957.mpg from (Transcoder Running at 6mbps: 10m5s @ 2.69x (73.95fps)).

Previously it just said transcoder ready

Tried another recording and getting lots of interlacing artefacts and weirdly look like transcoder is doing nothing:

Watching recording The Jonathan Ross Show S15E05 2019-10-12-2204.mpg from (Transcoder Ready).

And same again from another channel:

Watching recording Celebrity MasterChef S14E08 2019-09-18 2019-09-18-1957.mpg from (Transcoder Ready).

I will try the same shows again on old transcoder..

Old transcoder:

Watching recording Hairy Bikers Route 66 S01E04 2019-10-10-1957.mpg from (Running: 4m23s).

Watching recording The Jonathan Ross Show S15E05 2019-10-12-2204.mpg from (Running: 5m24s @ 33.3x (73.07fps)).

Watching recording Celebrity MasterChef S14E08 2019-09-18 2019-09-18-1957.mpg from (Running: 5m13s @ 37.4x (72.28fps)).

Not the no “transcoder ready” messages and there are no striping deinterlacing artifacts

So Eric it looks like there is a big difference between old and new transcoders..

With the new one, once it gets to the status transcoder ready.. the streamed video looks rubbish and has lots of artefacts (basically like if you choose original instead of 720p)

With old transcoder it never says transcoder ready and there are no artefacts but you do get audio sync issues occasionally after skipping - but least its watchable!

i have posted the logs to support email going back over the last 30 mins... lots of weirdness in there!

(nulls, errors, illegal reorderings, missing refs ertc)

i will stick with old transcoder for now at 720p 6mb and try not to skip too much as that results in a watchable stream internally on fireTv .... look forward to your thoughts

Ah! Thank you for your patience in helping me understand what is going on here.

The thing you're looking for is a way to tell the system "always transcode the video", but you aren't always getting that with the new transcoder.

I believe what we are seeing is a change that happened between the old transcoder and the new one. The change was to be smarter about the requested bitrate vs the source material bitrate and to not do transcoding when it is not necessary to meet the request. I am guessing that some of the content is more than the 6mbits/second that you are requesting and some of it is under that limit. When the status says (Transcoder Ready) it is saying that it is serving requests that can be sent without transcoding.

It seems that we may need to create a special setting for the FireTV to say "always force transcoding" until we can fix these underlying issues.

sounds good to me .. i will send some sample videos over now :slight_smile: