Cannot Access Server Away From Home

Today, I cannot access my server away from home...I have tried with phone and Firestick at my son's house.

Internally, all is fine.

I have double-checked that port 8089 is properly forwarded to the server (as it has been).

I cannot figure this out.

Windows 10 did an update and restarted today, might that be my issue?

I do not know how to submit logs from Android phone app. It did say it submitted diagnostics.

Help, please and thanks.

Does load?

There is a certificate expiration issue affecting some android devices. If you can access the web UI and update to DVR prerelease that may help. Please also submit diagnostics from there under Support > Troubleshooting

It tells me the certificate expired.

I have submitted diagnostics, from the server.

Under troubleshooting, I do see this under remote access section (with red circled x): Connected to but SSL certificate is invalid.

I did an update, but that has not helped.

Well, after the update, internally, I no longer get seems to work, but no video when channel is selected. On local Firestick.

And, , internal video is back... :slight_smile:

Any suggestion for the certificate issue?


It's tied to your operating system. If the OS won't update their SSL/TLS libraries, or their store of root certificates, there really isn't anything that can be done. (That's kind of the problem with Android, manufacturers don't keep up with security updates, and users are left out in the cold.)

Which OS is at issue?
The server is on Windows 10.
The issue is affecting, at least, my Android phone and a Firestick 4k.
I would think an issue with any of these would be wide spread, in this community, but I don't see that.

It is the Android operating systems on the client devices. An intermediate root certificate in their OS stores expired 1 Oct. The only solution is to update the certificates and libraries on those devices, and such an update can only come from your device manufacturer.

Your DVR server has nothing to do with this issue.

For the technical details, see here:

Hmm. That sucks. I still am wondering how this doesn't seem to be affected so many others with Android and Firestick devices. I can't be the only one.

Can you share what model of Android device is having the issue?

The phone is an LG V60 and the Firestick is a Firestick 4k.

LG's update/support history has been spotty at best, and depending upon the revision of the Fire device, it may be on an even more ancient version of Android with no upgrade path.

Without actual OS/build numbers, everything is a guess.

Here is the phone info. Firestick is at son's house, so don't have that handy.

Please turn remote access off and back on.

You may also need to use the android beta app which has a fix for the expiration issue.

Okay, I will give those a try, in a bit. Thanks for the help.

I turned remote access off and on, but still no joy.

How do I install the android beta?

If my issue is with my apps, why is this on my server?

Even if I try to access from a browser in Windows, I get warnings.