Cannot find HDHR thru OpenVPN anymore iOS

Hello!

What used to work no longer does.

I used to be able to connect to my HDHR via OpenVPN when on travel, either thru cellular data or hotel wifi, and watch TV with the CHANNELS app. Initially, I had to manually add the HDHR IP address into the Channels App on my iPhone, but after that the app seemed to remember the setting. Worked like a charm.

Since this week this no longer works. I am connected to my VPN that connects me to my home network. The channels app does no longer load the guide. When trying to add the HDHR, I get an error message "No HDHomeRun detected on ". Entering this IP address into my Safari browser on the iPhone takes me straight to the HDHR device's website (the one where one can view the channel line up, etc.). So the routing seems to work on the OpenVPN side. I checked the OpenVPN config, nothing seemed to have changed, as far as I can see.

Coming to think of it, I updated the HDHR firmware earlier this week.

HDHR Device ID: 10667519

( I saw someone had a similar issue with a different VPN setup, "Connect through Wireguard VPN Setup". Didn't want to muddy the waters there, hence this new post. )

Any insight will be appreciated. Thanks all!

Could you click Submit Diagnostics on the app after trying to add the HDHR over VPN

Done. :blush:

Hmm not seeing anything come through. Whats the version number shown in the app?

oops... had the VPN still on when trying to submit the log. Sorry. Trying to submit again.

I see Version 3.2.43

The OS is returning an error on http access:

error: url=http://10.0.78.33/discover.json error=Error Domain=NSURLErrorDomain Code=-1009 "The Internet connection appears to be offline." UserInfo={_kCFStreamErrorCodeKey=50, NSUnderlyingError=0x283d81020 {Error Domain=kCFErrorDomainCFNetwork Code=-1009 "(null)" UserInfo={_kCFStreamErrorCodeKey=50, _kCFStreamErrorDomainKey=1}}, _NSURLErrorFailingURLSessionTaskErrorKey=LocalDataTask <1FC02ED2-A5DF-46C3-B08D-6A68AF5E542B>.<2>, _NSURLErrorRelatedURLSessionTaskErrorKey=(
"LocalDataTask <1FC02ED2-A5DF-46C3-B08D-6A68AF5E542B>.<2>"
), NSLocalizedDescription=The Internet connection appears to be offline., NSErrorFailingURLStringKey=http://10.0.78.33/discover.json, NSErrorFailingURLKey=http://10.0.78.33/discover.json, _kCFStreamErrorDomainKey=1} response=(null) body=(null)

Hm. Strange.
If I enter the URL shown (http://10.0.78.33/discover.json) into Safari on iOS, VPN on, I get this:

{"FriendlyName":"HDHomeRun CONNECT DUO","ModelNumber":"HDHR5-2US","FirmwareName":"hdhomerun5_atsc","FirmwareVersion":"20200521","DeviceID":"10667519","DeviceAuth":"sl6qAX2lW8webbNt5t4fxEyA","BaseURL":"linkremoved","LineupURL":"linkremoved","TunerCount":2}

Had to remove the links to comply with new user posting restrictions.

EDIT: I have two questions:

  1. Could the error you're pointing out have occurred because I disconnected the VPN to submit the Diagnostic log?
  2. If this error is legit and not because I turned off the VPN prior to submitting the log: Any hint how I could fix this error? It seems to me the routing to the HDHR seems to work if I access it from Safari on the same device.

Do you maybe have data turned off for the Channels app or something?

Just checked. Mobile data for channels app is turned ON.

Let me go to an off-site location with WiFi, and see if it works with WiFi. Thus far I tried mobile data only.

BRB.

Aaaaalright.
Just went to a retail store and used the Guest-WiFi.

Worked like a charm. Well, sort of. The guide loads, and then I can select a station to watch, and then I run into buffering issues. Not unexpectedly so, I often see that with hotel WiFi connections as well. Hence my desire to be able to use mobile data.

EDIT: Still does not work with cellular data.

Maybe your carrier is throttling or disabling use of VPN...many are doing that now.
Use of a VPN was my trick to bypass the annoying video quality throttle to 480p, enabled PIA or my custom OpenVPN, and i could stream FHD video over mobile data. After a few months, it stopped working, neither VPN would work over mobile LTE connection anymore.

Very strange that safari would be able to connect but not our app using the same underlying NSURL apis.

Hi Cheetah:

Interesting.
My VPN works for pretty much for everything except for the Channels App. And the Channels app worked fine over VPN using cellular data until a few days ago. There is no throttling that I can tell. I'm hosting the VPN server myself, so I'm pretty sure there's no blocking going on from the VPN.
I can watch TV over VPN using VLC, by the way.

Running a speed test on my iPhone over the VPN gives these results: 21.4 Megabit/s Down, 6.4 Megabit/s Up.

Cheers!

Yes, agree. And: I can watch TV using VLC over VPN.

How long does it take to load in the browser?

Never mind, this is the same thing as Connect through Wireguard VPN and was fixed recently. It's not in the App Store build yet.

1 Like

Oh, OK. Thank you. I'll wait, then. :blush:

To answer your question: It's instantaneous in the browser.