Can't access at my IP:8089 at home (Synology)

Hi :slight_smile:

Very new to this so I am sure I am missing something obvious; apologies therefore for my naivete…

I installed the beta DVR package on my Synology NAS and it gave me the link to access as the IP of my synology with “:8089”

When I click that link, I get nothing; a blank screen… it looks like it’s trying to access it but it isn’t going anywhere…

Can anyone tell me what I am missing? I have a feeling I need to open port 8089 but any suggestion would be welcome :slight_smile:

Thanks :slight_smile:

Have you clicked on the DVR in your Synology apps interface to start it? It may not be running?

What IP is it showing? Should be the local IP of your Synology itself. No need to open ports since its all local inside your network.

If you go to the Package Center does it show Channels DVR as “Running” underneath the name?

If the IP of your Synology is 192.168.1.100, then you’d need to browse to 192.168.1.100:8089. Sometimes the Synology Package links don’t work well, so I’d just manual type it in or make a Bookmark for it.

Wow :slight_smile: Thanks for the really quick reply.

I’ll try to answer both replies at the same time :slight_smile:

The IP that is showing is, indeed, my Synology’s IP. The program does show a status of “Running”

I haven’t tried manually entering the IP address, followed by 8089; I just clicked the link in the listing of the beta in Package Center I will have to try that when I get back home and see if that works.

Trying it remotely from here at work (clicked on and manually typed in the quickconnect web address in this case) and still getting nothing btw…

If manually typing in the IP with 8089 doesn’t work at home, are there any other ideas as to why this has happened? I think I read somewhere scanning through the forum here that I might need to reboot the NAS and that may do the trick. Opinions on that?

Thanks :slight_smile:

If you’re accessing your synology remotely, then you’re likely using your public internet IP and port 8089 isn’t routed back to your synology. The setup expects that you are on your local network.

Once you finish the setup, you can enable the remote access feature in the DVR and access it remotely via port 8089 (it will open the port for you).

True. I guess I’l just have to look into it when I get home and see what happens. :slight_smile:

Thanks again :slight_smile: Crossing fingers that manually putting in the local address with 8089 will work…

ok… So I tried typing the address manually with :8089 and… nothing again. The error message I am getting is “This page isn’t working. didn’t send any data. ERR_EMPTY_RESPONSE”.

Any advice as to what do do would be very helpful.

Thanks :slight_smile:

What is the IP address you are using?

It’s possible the DVR isn’t running. You can try stopping and starting it from the apps interface.

I took a screenshot from the Package Center, showing the IP address; the NAS does indicate that it is running as you can see.

Please let me know if you need more from me.

Thanks again :slight_smile:

I have the DS Video app on my AppleTV and it can access my video files on the NAS perfectly fine. I am fairly certain that my network is 192.168.2 as everything on my network has that basic IP root.

One thing that I do not see in the main menu of my Synology NAS is any app for Channels; the only reference to Channels DVR can be found in Package Center. Is that normal?

Try uninstall and reinstall perhaps?

What version of DSM are you running? What NAS model?

That’s what I am thinking too… just uninstalled and re-installing now… Will let you know…

I’m running the most recent DSM version (6.1?) on an, admittedly, basic Synology NAS (BC115j)

Is mine not powerful enough to handle the DVR app? I know it can’t run Plex for example…

Hmmm… now thinking that it isn’t capable of running the app…

Reinstall results in the same error message when I go to 192.168.2.45:8089…

Make sure you have the latest 1.0.3 spk too

I think I do; the file I downloaded says ChannelsDVR_1.0.3.spk

Is there supposed to be an app? Because, other than what is listed in the Package Center, I am still not seeing anything anywhere else…

Not sure offhand.

Are you able to ssh in and run a few commands? That would help figure out what’s happening.

ps aux | grep channels

ls -alh /volume1/@appstore/ChannelsDVR/channels-dvr/data/

cat /volume1/@appstore/ChannelsDVR/channels-dvr/data/channels-dvr.log

ok… I think it’s all due to the fact that the NAS is just not up to the task, based on these specs…

Hardware Specifications
CPU

CPU Model Marvell Armada 370 88F6707
CPU Architecture 32-bit
CPU Frequency 800 MHz

Memory

System Memory 256 MB DDR3

Can anyone just officially confirm that this is the reason and put me out of my misery, please? :slight_smile:

It should still run and be accessible on those specs. I don’t think anyone has tried on these “BeyondCloud” models yet so that might be why it’s giving you so much trouble.

Thank you for your help so far. I will ssh in tomorrow and report back.

The log, incidentally, pretty much only says that it found 0 devices

Oh so you can access the log? That suggests the service is running. Can you paste the whole thing.