Can't find DVR server (windows bonjour with multiple ips/interfaces)


#1

Hi All,

Just reinstalled DVR service on a new computer(W10). Old computer turned off. Server installs on the new system fine and is up and running, recognizes tuner, etc. ATV clients(2) do not recognize the DVR. Any quick pointers? Do I need to reinstall ATV app?

2017/09/24 08:23:13 [DVR] Fetching guide data for 68 stations in USA-OTA02878 @ 2017-10-15 2:00AM
2017/09/24 08:23:15 [DVR] indexed 37 airings (4 channels) [1s fetch, 0s index]
2017/09/24 08:23:16 [IDX] Pruned 1 expired airings from USA-OTA02878 in 39.998ms.
2017/09/24 08:27:13 [SYS] Starting Channels DVR v2017.09.01.0513 (windows-x86_64) in C:\ProgramData\ChannelsDVR\data
2017/09/24 08:27:19 [HDR] Found 1 devices
2017/09/24 08:27:22 [SYS] Started HTTP Server
2017/09/24 08:28:05 [DVR] Recording engine started in C:\Users\dspitz\Downloads
2017/09/24 08:28:05 [SYS] Bonjour service running for dvr-lenovolt.local. [192.168.56.1 10.0.1.71]
2017/09/24 08:28:05 [SYS] Created database snapshot: backup-20170924.082805
2017/09/24 08:28:15 [IDX] Pruned 0 expired airings from USA-OTA02878 in 95.9926ms.


#2

Looks like you have 2 IPs. bonjour may not be broadcasting in the right IP.


#3

What does http://127.0.0.1:8089/system/network say?

What is the ip of your Apple TV?


#4

Hi,
Two ATV’s

10.0.1.88
10.0.1.3

[{“mtu”:1500,“name”:“Ethernet”,“hardwareaddr”:“00:26:2d:fb:03:fd”,“flags”:[“broadcast”,“multicast”],“addrs”:[{“addr”:“fe80::61e3:2d53:65bc:e190/64”},{“addr”:“169.254.225.144/16”}]},{“mtu”:1500,“name”:“Ethernet 4”,“hardwareaddr”:“0a:00:27:00:00:10”,“flags”:[“up”,“broadcast”,“multicast”],“addrs”:[{“addr”:“fe80::adde:fc98:7535:8078/64”},{“addr”:“192.168.56.1/24”}]},{“mtu”:1500,“name”:“Local Area Connection* 2”,“hardwareaddr”:“00:24:d7:0c:60:ad”,“flags”:[“broadcast”,“multicast”],“addrs”:[{“addr”:“fe80::91cb:7f4b:d5d2:aecb/64”},{“addr”:“169.254.174.203/16”}]},{“mtu”:1500,“name”:“Wi-Fi”,“hardwareaddr”:“00:24:d7:0c:60:ac”,“flags”:[“up”,“broadcast”,“multicast”],“addrs”:[{“addr”:“fe80::5c25:131b:ade1:1410/64”},{“addr”:“10.0.1.71/24”}]},{“mtu”:-1,“name”:“Loopback Pseudo-Interface 1”,“hardwareaddr”:"",“flags”:[“up”,“loopback”,“multicast”],“addrs”:[{“addr”:"::1/128"},{“addr”:“127.0.0.1/8”}]},{“mtu”:1280,“name”:“Local Area Connection* 13”,“hardwareaddr”:“00:00:00:00:00:00:00:e0”,“flags”:[“up”,“pointtopoint”,“multicast”],“addrs”:[{“addr”:“2001:0:9d38:953c:243d:1fcb:f5ff:feb8/64”},{“addr”:“fe80::243d:1fcb:f5ff:feb8/64”}]


#5

Looks like your machine is connected to ethernet (192.168.56.1) and wi-fi (10.0.1.71). You seem to be using the 10.x wifi network. Do you know why the ethernet network is different?

You can force the DVR to advertise over the wifi network only, by running the following command in powershell:

Invoke-WebRequest -UseBasicParsing -Method PUT http://127.0.0.1:8089/bonjour/interface/Wi-Fi

Then uncheck and re-check the bonjour checkbox on the DVR settings page.


#6

Thanks. I was just typing a response before I saw your message… I was curious why the two IP numbers as mentioned by imnotserious.

I checked ipconfig, saw an “ethernet 4” with the 192. address. I believe it was created by virtualbox(which I was not using). I deleted VB, and sure enough eth 4 was removed… restarted ATV and everything worked. Thanks for the command string, could be helpful in the future.


#7

I get two ip addresses under the bonjour settings when I am using a vpn. The original and the new one. Then all of a sudden Channels DVR doesn’t get recognized in the apps. I only have Ethernet on my Windows 10 PC so I don’t know if that affects it.


#8

You mean you’re connecting to a VPN, as a client? Or are you running a vpn server?

The vpn must be creating a virtual network interface with it’s own IP. Check what http://127.0.0.1:8089/bonjour says before and after.


#9

Yeah it is running as a client. Torguard to be exact. Here is what it says…

{“addresses”:[“10.65.124.***”,“192.168.***”],“enabled”:true,“hostname”:“dvr-hartsellpc.local.”,“interfaces”:[“Ethernet 2”,“Ethernet”]}


#10

You can run:

Invoke-WebRequest -UseBasicParsing -Method PUT http://127.0.0.1:8089/bonjour/interface/Ethernet


#11

Nice! Now it only shows my 192.168 ip address! Thanks! When this problem started a few weeks ago I also noticed that my “Log-in to remote DVR” function on the app doesn’t work. After I authorize it the app gives me the “DVR Access Failure.” Is there a way to reset this or something on your end for me? It used to work perfectly!


#12

Hey @Lvevan , I’ve just finished a big update to our bonjour server which now makes it multi-interface and multi-IP aware. It’s available in the latest DVR pre-release which you can update to manually via the web UI. See NEW: DVR pre-release with Bonjour update (v2018.03.27.0215)

Would you mind testing this out for me and let me know if it works as expected? With the new build, you no longer need the “preferred interface” hack that you’ve been using. So basically update to the pre-release (hold down SHIFT key and click Check for Updates), then remove the preference you had previously set with a command like:

iwr -Method Delete http://127.0.0.1:8089/bonjour/interface


#13

Awesome! Works like a charm. It now says Advertising dvr-hartsellpc.local. via 3 networks. Not sure what the third network is because only two are listed… when I uncheck then recheck the Bonjour box it says I am advertising 2 networks and the same two ip addresses are listed.

I also noticed that the Port Forwarding option when set to manual now lists my vpn’s local ip (which is the other ip the bonjour lists) next to the “Configure your router to forward…” text. But I only need to have my regular local ip in my routers port forwarding settings for it to work. Not sure if that will confuse people.


#14

@Lvevan Can you send me the output from http://127.0.0.1:8089/system/network


#15

Just emailed it!