Can't re-add HuluLive TVE

I've been having issues with the Discovery suite of TVE channels so thought I would try deleting and then re-adding the source. However when I enter my Hulu creds to start the process, it just stalls and then throws the attached error screen so I can't even add it back.

1 Like

Update to prerelease first

That did it. Thanks!

I'm experiencing login failure also trying to add Hulu Live back. I'm receiving a a cable provider authentication failed message. I never see the prompt to enter the verification code. I'm on the latest prerelease version 2022.07.06.1622.

Does it work in chrome incognito on nbc.com/live before you add it to the dvr

I'm using Linux (Ubuntu). I tried Chromium and Iron with incognito windows and they gave a "Error: Your login has been blocked." error. However, in Firefox it does work with nbc.com/live, but Channels DVR doesn't work in Firefox either. Also tried Waterfox (Firefox based) in a private window and it worked with nbc.com/live, but not Channels DVR.

I started Windows Server 2012 R2 in a VirtualBox VM, started Chrome, and updated to the latest version of Chrome. Started an incognito window, logged into Hulu successfully through nbc.com/live, but Channels DVR gave the same cable provider authentication error.

I haven't updated Channels DVR since my last post. I remembered that I had the Falkon web browser installed and decided to try it. Worked with NBC and it didn't have me input a verification code. Tried adding Hulu again in Channels DVR and it worked. I also didn't have to put in a verification code for Hulu for Channels DVR. I don't know if Falkon is making the difference, or if something else has changed.
channelsDvr_FalkonBrowser

Running the latest pre-release for 7.19 on my shield TV, and I am still getting this error. Is there another way to test it? I can log in fine from my computer.

Have been experiencing this error for two days. Running pre-release 2022.07.19.2302 on MacOS 10.15.

Below is what is in the log:

2022/07/20 19:44:16.013173 [TVE] Auth starting for Hulu as [email protected]
2022/07/20 19:44:16.313834 [TVE] action=auth mvpd=Hulu requestor=nbcentertainment
2022/07/20 19:44:16.618413 [TVE] action=version product=HeadlessChrome/93.0.4577.63 jsVersion=9.3.345.16 protocol=1.3 [email protected]
2022/07/20 19:44:16.619141 [TVE] action=mock
2022/07/20 19:44:16.624756 [TVE] action=navigate url=https://sp.auth.adobe.com/adobe-services/authenticate/saml?noflash=true&mso_id=Hulu&requestor_id=nbcentertainment&no_iframe=true&domain_name=adobe.com&redirect_url=https%3A%2F%2Fsp.auth.adobe.com%2Fadobe-services%2FcompletePassiveAuthentication
2022/07/20 19:44:16.625764 [TVE] action=request type=Document method=GET url=https://sp.auth.adobe.com/adobe-services/authenticate/saml
2022/07/20 19:44:16.903484 [TVE] action=request type=Document method=GET url=https://auth.hulu.com/oauth2/login
2022/07/20 19:44:16.903512 [TVE] action=auth_domain domain=.hulu.com
2022/07/20 19:44:17.072292 [TVE] action=wait_for_page
2022/07/20 19:44:22.353561 [TVE] action=page_ready
2022/07/20 19:44:22.353654 [TVE] action=wait_for_page done=true reason=page_ready
2022/07/20 19:44:22.353678 [TVE] action=fill_form [email protected]
2022/07/20 19:44:22.356329 [TVE] action=screenshot
2022/07/20 19:44:22.436534 [TVE] action=screenshot size=20949
2022/07/20 19:44:22.436796 [TVE] action=capture_html
2022/07/20 19:44:22.439586 [TVE] action=capture_html size=91907
2022/07/20 19:44:22.439919 [TVE] action=script_error err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught", LineNumber:252, ColumnNumber:27, ScriptID:"435", URL:"", StackTrace:(*runtime.StackTrace)(0xc0018cac00), Exception:(*runtime.RemoteObject)(0xc0011b06c0), ExecutionContextID:0, ExceptionMetaData:easyjson.RawMessage(nil)} exp=&runtime.RemoteObject{Type:"object", Subtype:"error", ClassName:"TypeError", Value:easyjson.RawMessage(nil), UnserializableValue:"", Description:"TypeError: Illegal invocation\n    at reactValueSet (tveloginhelper.js:253:28)\n    at huluLogin (tveloginhelper.js:87:5)\n    at tveloginhelper.js:375:5", ObjectID:"2628851319964285018.2.2", Preview:(*runtime.ObjectPreview)(nil), CustomPreview:(*runtime.CustomPreview)(nil)} exp_value=TypeError: Illegal invocation
    at reactValueSet (tveloginhelper.js:253:28)
    at huluLogin (tveloginhelper.js:87:5)
    at tveloginhelper.js:375:5
2022/07/20 19:44:22.455833 [TVE] Auth failed for Hulu: TypeError: Illegal invocation
    at reactValueSet (tveloginhelper.js:253:28)
    at huluLogin (tveloginhelper.js:87:5)
    at tveloginhelper.js:375:5

Fix for Hulu issue in next prerelease.

The new release fixed it!

1 Like

Nov 16, 2022
Hi!
I am having issues adding HULU LIVE as a TVE host on the DVR server.
I am running Version 2022.11.16.2224
What happens is I get an image screen saying I need to input a code to authenticate my Hulu credentials (many many people have posted this image already so this is a known issue) then at the same moment I get an email with a code to input for TFA but of course, the DVR image notification has no way to input the code and its a bomb HULU LIVE will not add as a host. I had this happen before but I think it was just dumb luck that I tried adding HULU live as a host like a 2 AM and it just did it no issues but that was then and it is back to not allowing the DVR to add it as a host. Maybe has something to do with location requests are seemingly hard blocked (check site setting) on browsers looking at local LAN addresses?? IDK. But I noticed that HULU will ask that location be shared when I login via a web browser that connects over port 443. If you don't share you then get that email with the code and that works of course as I have that window open live to respond to whereas on the DVR image is just an image. Well, anyway any help with this ongoing HULU LIVE issue would be much appreciated as I can not use my DVR until I can get HULU LIVE back on as the TVE host! Right now I have no host!
Thanks!
-Geo

On the server machine open a chrome incognito tab and go to Hulu.com and login to watch a show. When it asks for a code type it in. Allow location of it asks. After login with the code is complete leave this tab open and then open another tab to the channels server page and re add Hulu as a source. It has to be the server machine and chrome incognito as Hulu is adding the machine to its authorized devices list. Hulu doesn’t use TFA per say. This is a one time code to authorize the device and won’t ask for codes after that unless a password or administrative change is made.

1 Like

Nov 11, 2022
Hi Rice!
After reading and re-reading your comment I realize you are saying to use the browser from the DVR server? My server is a Raspberry Pi running the DVR software from getchannels. I have no idea what user credentials are to login into that device remotely and if I did it does not respond to VNC at all. I have not tried to hook a monitor/keyboard/mouse to it locally as I thought it is a locked system that gechannels automatically maintains the OS and software on? I will give it a shot when I find my micro HDMI cable adapter to plug into the R-Pi. If it is a server environment however there may be no browser installed in the OS per se. But we'll see.
Thanks!
-Geo

Correct

There is no way to do what I’m saying with the pi with channels image.

If I were in your shoes, I would image the pi to raspberry pi os and run the Linux version of channels dvr on it and follow the the steps to migrate your server and move your recordings documentation.

This would allow you to install a chrome browser and proceed with the code steps. Currently the channels image only uses a headless chrome that you can’t pull up a gui browser. Probably not what you wanted to hear but this in my experience with Hulu. Running your server machine on something with a web browser is a must.

Another thing you could try is shutdown and unplug all the channels image usb/card then grab an unused microhd card and flash pi os in it, install chrome. Follow the steps to authorize with code, then after that reboot with all the channels os. Worth a try to not have to migrate the server.

Ok, sadly I face the same problem. Cannot add Hulu Live TVE to channels.
I am running the latest DVR server on macOS Ventura, with the most recent Google Chrome release. I logged into Hulu in an incognito Chrome window, next tab nbc.com/live works without re-authentication, next tab 127.0.0.1:8089 add Hulu TVE still fails with the 2FA error code ... Really bummed out right now ...

Did you login to Hulu to “watch” programming? For some reason it didn’t ask for the code when logging in to the Hulu settings admin page. But to actually watch live it did require the code. This is for the code required after a password reset that they forced on me.

Do you have a screenshot from your server ip @
http://xxx.xxx.x.x:8089/providers/tve/error_screenshot.png

If so can you post a a screenshot of it

Also perhaps this might work. Login to Hulu settings on your phone, initiate adding Hulu in channels as a source and when you get the email with the code try adding it in the Hulu page. I don’t know if this will work.

Sadly the code with the phone also didn’t work. Here is the screenshot from the error earlier…