Channel 6002 Fox is suddenly missing from TVE lineup

Using Xfinity TVE. I no longer have Fox. I’ve updated to latest pre-release.

  1. From a device that isn't your DVR (unless NAT hairpinning is enabled on your router), go to and log in.
  2. On this device, make sure to allow location access for the browser and the site.
  3. Near the bottom of the Settings page, disable the Experimental Local Networks via TV Everywhere setting, let the page reload, and then re-enable it, making sure to accept any prompts for location access requests.
  4. It might take a few minutes, but the DVR should be able to use your credentials to successfully authenticate with Fox.

(Per your screenshot, your iPhone will work for this.)


Done. Boom. This fixed it.

Thanks for your help.


Not sure if this is related but today i can't log into any of my Locals TVE. i get this error message

Post "": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

I tried what you listed earlier to reenable location on my phone but still get same message. any help would be appreciated.

I'm having the same issue with Fox, but my other TVE channels are ok, but are slow to authorize.

Have you tried rescanning FOX?

I had the same issue as well with FOX and CBS about three hours ago, but other locals worked fine. A few minutes ago, I tried both again, and CBS had started working on its own, but FOX still wouldn't authorize. I then rescanned FOX, after which it started working again.

However, it might also have been a coincidence timing-wise that rescanning fixed it for me, since this error likely indicates an issue outside of Channels.

Some likely causes of the same error from others' recent posts: