Channels DVR App Quits Immediately on Sony Bravia ATV


I have a Sony Bravia running Android 8.0.0. My Channels DVR app appears to have updated recently to version 2.1.16.

Possibly coinciding with that app update, I am no longer able to open the app. As soon as it launches (the screen turns purple for an instant), it quits and returns me to whatever screen I was on.

I have tried:
Rebooting the TV
Wiping the app's storage
Uninstalling app > Rebooting > Reinstalling app from Play Store

But still experiencing the same behavior - I'm unable to open the app. Any suggestions?

Thank you!

Same problem on Shield with the latest update.

Also just tried restarting the DVR service (running on my NAS) but that did not affect the issue. Confirmed I am able to connect and use Channels DVR with no problems on my Android phone (Moto Z3) running Android 9 and Channels DVR app 2.1.16.

I have the same problem on a 2019 Shield. Also restarted everything with no effect and cleared cache, etc. 2.1.16 appears to be broken.

Same issue here on a Sony Bravia TV.

Same here. Works on my original shield tv but not on my newer Sony TV 950G. Both are on 2.1.16

Same issue here on Mibox. Tried to reinstall, but I'm getting the same thing. Something in the update is definitely causing an issue.

Issue has been found and fixed, just waiting on app stores to push the updates out.

It also crashes on my Sling AirTV Player. I was just using it and decided to update the app and now it doesnt work. I also have an nvidia shield but im not willing to update that just to see if it works.

Thanks for merging the threads!

Channels for Android version 2.1.17 is now available on the Google Play Store.

This resolves the issue from yesterday. You can manually update from the store to get it faster.

1 Like

Thank you!