Channels DVR server no longer sees HDHR tuner after updating its firmware

My OTA channels stopped working this morning, and when I checked the HDHomeRun app on my pc I saw that it was paused. It forced me to upgrade my firmware to 20230323 and restart, but since doing so it has disappeared as a source on my Channels server page.

I clicked the gear icon at the top of the sources box and chose Scan Network (no luck), tried to manually add the HDHR by inserting it's IP address (no luck), updated to the latest prerelease 2023.04.04.1812 (nothing), rebooted Channels (nothing), waited awhile then rescanned the network and tried manually adding the HDHR again (no luck), then finally restarted the Mac mini the server lives on and rescanned the network (still nothing). :sob:

The only anomaly I've found is that the system page on hdhomerun.local shows its IP address at, while my router page shows it at I've tried manually adding both IP addresses but neither works.

The HDHomeRun app plays fine on my Apple TV and pc, so the box is working after the update. I don't know what else to try. Any ideas?

1 Like

Sounds like you are double natting. I'm guessing your channels server is on wifi. Long term you want to eliminate the double nat and put your access point in bridged mode. Also usually always better to hard wire your channels server as well. In the mean time however, just move the channels server and HDHR's on the same subnet and all should work fine.

No everything is hard wired--Mac mini, PC, HDHR, Apple TVs are all on ethernet. My OTA channels worked fine until this morning, and I haven't changed any settings other than to upgrade the HDHR to the latest firmware, which it forced me to do.

1 Like

Somehow you have 2 subnets going on the HDHR got whacky. Have you power cycled it?

1 Like

Yes, I power cycled the HDHR a couple of times already. Oh and btw, the router says there is no device at where the HDHR claims to be, according to its System Status page.

1 Like

So you can get to the status page on the HDHR right now?

1 Like

If you can get to HDHR address then you have a double NAT. You have 2 different subnets. You've got to trace cables, verify VLANs, and figure out where it is coming from.

1 Like

Sorry for the spam here but reply back with the following
Channels server ip
(any vpn' s multiple network adapters etc? )

Appletv ip
Router internal address

These are private ips so no need to mask them

1 Like

According to the router page, HDHR was at, but after I clicked "Clear and Rescan for Devices" it no longer has the name listed.

The Router page says I have 9 ethernet clients, 5 are weird though. One unknown at, two iPads at & which have to be misidentified because they're wifi only, and two nonsense devices at 2600:1700:ae0f:e000:218:ddff:fe06:26be / unknown0018dd0626be and fe80::a62b:8cff:fe32:5e53 / unknowna42b8c325e53

In reality I only have 6 ethernet clients: 2 Apple TVs, a Mac min, a PC, an HDHR, and a Nintendo Switch.

But you can reach and browse the HDHR on from

Does your wan ip on your router show a public address or something in the space?

No, but I can't paste and browse any of my devices except my printer and router.

All my devices IP address start with 192.168.1 I don't have any with a 0 in the third space.

Sorry, I'm not computer savvy enough to be much help. :cry:

What kind of router do you have?

Are all the devices plugged directly into the router? Or do you have other devices plugged in like switches or access points, etc?

If you list out all the devices models and brand names and how they're connected that will help narrow down the issue.

1 Like

You might want to try and reboot the router.. Sometimes the HDHomeRun units have a problem getting an IP.

I have an AT&T fiber router, model BGW320-505.

Port 4 goes to a Mac Mini
Port 3 to an Apple TV
Port 2 to another Apple TV
Port 1 goes up into the attic, then down into the back office, and into an old Netgear cable router that I'm using as an ethernet switch (model #CG3000Dv2).

Port 1 of the Netgear switch is the line down from the attic.
Port 2 goes into a Nintendo Switch.
Port 3 an old PC
Port 4 the HDHR box

Thanks, but I've already tried that as well.

Can you look at the back of the Tuner where the Ethernet gets plugged in and see if you have a red light? ?

There was a red light when I first plugged it back in, but that quickly went away, and now there is only a green light over the ethernet plug. And, as I mentioned earlier the HDHR native app plays fine on all my devices. I just can't get Channels to find it.

1 Like

You are trying to use a router as a switch and that is creating a second network.

See if the netgear has settings to operate in bridge mode so the devices connected to it use 192.168.0.X addressing

1 Like

There's no cable plugged into it, only the 4 ethernet ports

I don't know how to do that/if it's possible. I search the manual, and it doesn't say anything about bridge mode. N450 WiFi Cable Modem Router N450/CG2000Dv2 User Manual (